boot/uboot: add stm32 binary format
authorShlomi Vaknin <shlomi.39sd@gmail.com>
Wed, 7 Oct 2020 14:49:42 +0000 (17:49 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 13 Oct 2020 20:41:41 +0000 (22:41 +0200)
Add `.stm32` binary format that U-Boot generates for the trusted
configuration of STM32MP platforms.

Signed-off-by: Shlomi Vaknin <shlomi.39sd@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
boot/uboot/Config.in
boot/uboot/uboot.mk

index 41cc1e1fdda4bcfe3a05e59b76f9a37e892d8784..e4a0f48debd591c2ced4d9dcf86c513af200ec67 100644 (file)
@@ -343,6 +343,10 @@ config BR2_TARGET_UBOOT_FORMAT_SD
 
          See doc/README.mxs (or doc/README.mx28_common before 2013.07)
 
+config BR2_TARGET_UBOOT_FORMAT_STM32
+       bool "u-boot.stm32"
+       depends on BR2_arm
+
 config BR2_TARGET_UBOOT_FORMAT_CUSTOM
        bool "Custom (specify below)"
        help
index f27abbd5ba0e7d0b48bd7c3ce17cbe5964edc346..72d5df412dc2eecd73563e846a933ba7c31aa8ec 100644 (file)
@@ -121,6 +121,11 @@ UBOOT_MAKE_TARGET += u-boot.sb
 UBOOT_DEPENDENCIES += host-elftosb host-openssl
 endif
 
+ifeq ($(BR2_TARGET_UBOOT_FORMAT_STM32),y)
+UBOOT_BINS += u-boot.stm32
+UBOOT_MAKE_TARGET += u-boot.stm32
+endif
+
 ifeq ($(BR2_TARGET_UBOOT_FORMAT_CUSTOM),y)
 UBOOT_BINS += $(call qstrip,$(BR2_TARGET_UBOOT_FORMAT_CUSTOM_NAME))
 endif