download: add missing '-d' option
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Mon, 2 Apr 2018 14:58:01 +0000 (16:58 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 2 Apr 2018 15:48:56 +0000 (17:48 +0200)
The infrastructure needs to give the 'dl_dir' to the dl-wrapper which in its
turn needs to give it to the helper.  It will only be used by the 'git'
helper as of now.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-download.mk
support/download/dl-wrapper

index 4fdb283acce0a1483fee119eaba747d24127e73a..b7f1d439202d1c4919693a006775333592d87d5b 100644 (file)
@@ -96,6 +96,7 @@ define DOWNLOAD
                BR_NO_CHECK_HASH_FOR=$(notdir $(call qstrip,$(1)))) \
        $(EXTRA_ENV) $(FLOCK) $(DL_WRAPPER) \
                -c '$($(PKG)_DL_VERSION)' \
+               -d '$($(PKG)_DL_DIR)' \
                -f '$(notdir $(1))' \
                -H '$(PKGDIR)/$($(PKG)_RAWNAME).hash' \
                -n '$($(PKG)_BASENAME_RAW)' \
index cd903f92d90f0722dac5eb70bb8c3f1c1e2ec684..af2950ac3bcfc57ee4e1fbce8b972346fabe658f 100755 (executable)
@@ -19,7 +19,7 @@
 # We want to catch any unexpected failure, and exit immediately.
 set -e
 
-export BR_BACKEND_DL_GETOPTS=":hc:o:n:N:H:ru:qf:e"
+export BR_BACKEND_DL_GETOPTS=":hc:d:o:n:N:H:ru:qf:e"
 
 main() {
     local OPT OPTARG
@@ -27,10 +27,11 @@ main() {
     local -a uris
 
     # Parse our options; anything after '--' is for the backend
-    while getopts ":hc:o:n:N:H:rf:u:q" OPT; do
+    while getopts ":hc:d:o:n:N:H:rf:u:q" OPT; do
         case "${OPT}" in
         h)  help; exit 0;;
         c)  cset="${OPTARG}";;
+        d)  dl_dir="${OPTARG}";;
         o)  output="${OPTARG}";;
         n)  raw_base_name="${OPTARG}";;
         N)  base_name="${OPTARG}";;
@@ -109,6 +110,7 @@ main() {
         if ! "${OLDPWD}/support/download/${backend}" \
                 $([ -n "${urlencode}" ] && printf %s '-e') \
                 -c "${cset}" \
+                -d "${dl_dir}" \
                 -n "${raw_base_name}" \
                 -N "${raw_name}" \
                 -f "${filename}" \