package/poco: bump version to 1.7.9
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 17 Sep 2017 17:58:17 +0000 (19:58 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 24 Sep 2017 13:42:52 +0000 (15:42 +0200)
Removed patch applied upstream:
https://github.com/pocoproject/poco/commit/30159aea4b3f6421da9d74a8bf22aad6d3bf26b4

Renumbered remaining patches.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/poco/0001-GNU-version-of-strerror_r-not-available-on-musl.patch [deleted file]
package/poco/0001-poco-add-the-staging-path-to-search-path.patch [new file with mode: 0644]
package/poco/0002-fix-m68k-double-conv-detect.patch [new file with mode: 0644]
package/poco/0002-poco-add-the-staging-path-to-search-path.patch [deleted file]
package/poco/0003-fix-m68k-double-conv-detect.patch [deleted file]
package/poco/poco.hash
package/poco/poco.mk

diff --git a/package/poco/0001-GNU-version-of-strerror_r-not-available-on-musl.patch b/package/poco/0001-GNU-version-of-strerror_r-not-available-on-musl.patch
deleted file mode 100644 (file)
index c2f297f..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-From 30159aea4b3f6421da9d74a8bf22aad6d3bf26b4 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?J=C3=B6rg=20Krause?= <joerg.krause@embedded.rocks>
-Date: Mon, 4 Apr 2016 20:48:43 +0200
-Subject: [PATCH] GNU version of strerror_r not available on musl
-
-The GNU version of glibc' `strerror_r` is non-portable.
-
-When the POSIX and GNU API collides musl always provides the POSIX API. That
-being the case for `strerror_r` musl does only support the POSIX version,
-despite of `_GNU_SOURCE`.
-
-[Upstream commit: https://github.com/pocoproject/poco/commit/30159aea4b3f6421da9d74a8bf22aad6d3bf26b4]
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- Foundation/src/Error.cpp | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/Foundation/src/Error.cpp b/Foundation/src/Error.cpp
-index 6a8afb705f..00991fc0be 100644
---- a/Foundation/src/Error.cpp
-+++ b/Foundation/src/Error.cpp
-@@ -69,7 +69,10 @@ namespace Poco {
-                  without -D_GNU_SOURCE is needed, otherwise the GNU version is
-                  preferred.
-               */
--#if defined _GNU_SOURCE && !POCO_ANDROID
-+              /* The GNU version of strerror_r is non-portable and not
-+                 available on the musl C library.
-+               */
-+#if (defined __GLIBC__ || defined __UCLIBC__) && defined _GNU_SOURCE && !POCO_ANDROID
-               char errmsg[256] = "";
-               return std::string(strerror_r(errorCode, errmsg, 256));
- #elif (_XOPEN_SOURCE >= 600) || POCO_ANDROID
diff --git a/package/poco/0001-poco-add-the-staging-path-to-search-path.patch b/package/poco/0001-poco-add-the-staging-path-to-search-path.patch
new file mode 100644 (file)
index 0000000..5695b62
--- /dev/null
@@ -0,0 +1,38 @@
+From b8417607ec8840e6a1e27cf03b6958c794a33e49 Mon Sep 17 00:00:00 2001
+From: Baruch Siach <baruch@tkos.co.il>
+Date: Tue, 4 Aug 2015 10:14:00 +0200
+Subject: [PATCH 1/2] poco: add the staging path to search path
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Add the mysql headers and client libraries to the search path of the
+preprocessor and the linker. The $MYSQL_LIBDIR / $MYSQL_INCIDR variables
+must be set from the make command line.
+
+[Peter: Remove host dirs, add MYSQL_INCDIR]
+Signed-off-by: Baruch Siach <baruch@tkos.co.il>
+[Jörg: Update to version 1.6.1 from github]
+Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
+---
+ Data/MySQL/Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Data/MySQL/Makefile b/Data/MySQL/Makefile
+index 0b18ca5..094e807 100644
+--- a/Data/MySQL/Makefile
++++ b/Data/MySQL/Makefile
+@@ -8,8 +8,8 @@
+ include $(POCO_BASE)/build/rules/global
+-SYSLIBS += -L/usr/local/lib$(LIB64SUFFIX)/mysql -L/usr/lib$(LIB64SUFFIX)/mysql -L/usr/mysql/lib$(LIB64SUFFIX) -L/usr/mysql/lib$(LIB64SUFFIX)/mysql -L/usr/local/mysql/lib$(LIB64SUFFIX) -lmysqlclient
+-INCLUDE += -I/usr/local/include/mysql/ -I/usr/include/mysql/ -I/usr/mysql/include/mysql -I/usr/local/mysql/include
++SYSLIBS += -L$(MYSQL_LIBDIR) -lmysqlclient
++INCLUDE += -I$(MYSQL_INCDIR)
+ SYSFLAGS += -DTHREADSAFE -DNO_TCL
+ objects = Binder Extractor SessionImpl Connector \
+-- 
+2.5.0
+
diff --git a/package/poco/0002-fix-m68k-double-conv-detect.patch b/package/poco/0002-fix-m68k-double-conv-detect.patch
new file mode 100644 (file)
index 0000000..3ca03fc
--- /dev/null
@@ -0,0 +1,19 @@
+Fixes compile for m68k.
+
+From upstream double-conversion commit da111796231:
+https://github.com/google/double-conversion/blob/master/double-conversion/utils.h
+
+Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
+
+diff -Nur poco-poco-1.7.2-release.orig/Foundation/src/utils.h poco-poco-1.7.2-release/Foundation/src/utils.h
+--- poco-poco-1.7.2-release.orig/Foundation/src/utils.h        2016-03-19 08:19:35.000000000 +0100
++++ poco-poco-1.7.2-release/Foundation/src/utils.h     2016-08-11 02:55:02.827238119 +0200
+@@ -63,6 +63,8 @@
+     defined(__AARCH64EL__) || \
+     defined(nios2) || defined(__nios2) || defined(__nios2__)
+ #define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
++#elif defined(__mc68000__)
++#undef DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS
+ #elif defined(_M_IX86) || defined(__i386__) || defined(__i386)
+ #if defined(_WIN32)
+ // Windows uses a 64bit wide floating point stack.
diff --git a/package/poco/0002-poco-add-the-staging-path-to-search-path.patch b/package/poco/0002-poco-add-the-staging-path-to-search-path.patch
deleted file mode 100644 (file)
index 5695b62..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-From b8417607ec8840e6a1e27cf03b6958c794a33e49 Mon Sep 17 00:00:00 2001
-From: Baruch Siach <baruch@tkos.co.il>
-Date: Tue, 4 Aug 2015 10:14:00 +0200
-Subject: [PATCH 1/2] poco: add the staging path to search path
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Add the mysql headers and client libraries to the search path of the
-preprocessor and the linker. The $MYSQL_LIBDIR / $MYSQL_INCIDR variables
-must be set from the make command line.
-
-[Peter: Remove host dirs, add MYSQL_INCDIR]
-Signed-off-by: Baruch Siach <baruch@tkos.co.il>
-[Jörg: Update to version 1.6.1 from github]
-Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
----
- Data/MySQL/Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/Data/MySQL/Makefile b/Data/MySQL/Makefile
-index 0b18ca5..094e807 100644
---- a/Data/MySQL/Makefile
-+++ b/Data/MySQL/Makefile
-@@ -8,8 +8,8 @@
- include $(POCO_BASE)/build/rules/global
--SYSLIBS += -L/usr/local/lib$(LIB64SUFFIX)/mysql -L/usr/lib$(LIB64SUFFIX)/mysql -L/usr/mysql/lib$(LIB64SUFFIX) -L/usr/mysql/lib$(LIB64SUFFIX)/mysql -L/usr/local/mysql/lib$(LIB64SUFFIX) -lmysqlclient
--INCLUDE += -I/usr/local/include/mysql/ -I/usr/include/mysql/ -I/usr/mysql/include/mysql -I/usr/local/mysql/include
-+SYSLIBS += -L$(MYSQL_LIBDIR) -lmysqlclient
-+INCLUDE += -I$(MYSQL_INCDIR)
- SYSFLAGS += -DTHREADSAFE -DNO_TCL
- objects = Binder Extractor SessionImpl Connector \
--- 
-2.5.0
-
diff --git a/package/poco/0003-fix-m68k-double-conv-detect.patch b/package/poco/0003-fix-m68k-double-conv-detect.patch
deleted file mode 100644 (file)
index 3ca03fc..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-Fixes compile for m68k.
-
-From upstream double-conversion commit da111796231:
-https://github.com/google/double-conversion/blob/master/double-conversion/utils.h
-
-Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
-
-diff -Nur poco-poco-1.7.2-release.orig/Foundation/src/utils.h poco-poco-1.7.2-release/Foundation/src/utils.h
---- poco-poco-1.7.2-release.orig/Foundation/src/utils.h        2016-03-19 08:19:35.000000000 +0100
-+++ poco-poco-1.7.2-release/Foundation/src/utils.h     2016-08-11 02:55:02.827238119 +0200
-@@ -63,6 +63,8 @@
-     defined(__AARCH64EL__) || \
-     defined(nios2) || defined(__nios2) || defined(__nios2__)
- #define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
-+#elif defined(__mc68000__)
-+#undef DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS
- #elif defined(_M_IX86) || defined(__i386__) || defined(__i386)
- #if defined(_WIN32)
- // Windows uses a 64bit wide floating point stack.
index c3b490ee0755572dafaffedf5c3f8c4115a24453..7f96f04d785ee1d033060869505a477f9a2ca87d 100644 (file)
@@ -1,2 +1,2 @@
 # Locally computed
-sha256  cfd311ecbc9e58accf1c4ea70170af88f92f88e73dd14944e528e7f6229e6cab  poco-poco-1.7.2-release.tar.gz
+sha256  150b8d8486fbd01f4bbe359a56439ccf14b62fb9994991baa9663a2656acee27  poco-poco-1.7.9-release.tar.gz
index c9ddeae3a94c91aa008e384934e3d29b9247f697..673b93a4f999415cab1f885b3635dbb7ac312048 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-POCO_VERSION = poco-1.7.2-release
+POCO_VERSION = poco-1.7.9-release
 POCO_SITE = $(call github,pocoproject,poco,$(POCO_VERSION))
 POCO_LICENSE = BSL-1.0
 POCO_LICENSE_FILES = LICENSE