bug 834: libusb: build fix: set big/little endian
authorEric Andersen <andersen@codepoet.org>
Fri, 14 Apr 2006 18:32:17 +0000 (18:32 -0000)
committerEric Andersen <andersen@codepoet.org>
Fri, 14 Apr 2006 18:32:17 +0000 (18:32 -0000)
 The following patch fixes a compilation error in libusb (cannot
 detectect endian while cross compiling)

package/libusb/libusb.mk

index 0fbb3bf28c407983216bc7c453500e202d06564e..9cb0d3fc85b5881159d07882e786120708c5d5a1 100644 (file)
@@ -11,6 +11,12 @@ LIBUSB_CAT:=zcat
 LIBUSB_BINARY:=libusb.la
 LIBUSB_TARGET_BINARY:=usr/lib/libusb.so
 
+ifeq ($(BR2_ENDIAN),"BIG")
+LIBUSB_BE:=yes
+else
+LIBUSB_BE:=no
+endif
+
 $(DL_DIR)/$(LIBUSB_SOURCE):
        $(WGET) -P $(DL_DIR) $(LIBUSB_SITE)/$(LIBUSB_SOURCE)
 
@@ -24,6 +30,7 @@ $(LIBUSB_DIR)/.configured: $(LIBUSB_DIR)/.unpacked
                $(TARGET_CONFIGURE_OPTS) CC_FOR_BUILD=$(HOSTCC) \
                CFLAGS="$(TARGET_CFLAGS)" \
                ac_cv_header_regex_h=no \
+               ac_cv_c_bigendian=$(LIBUSB_BE) \
                ./configure \
                --target=$(GNU_TARGET_NAME) \
                --host=$(GNU_TARGET_NAME) \