package/sslh: fix script, does not build in parallel
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 21 Feb 2017 21:12:22 +0000 (22:12 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 23 Feb 2017 20:50:38 +0000 (21:50 +0100)
The Makefile is not parallel-safe, so we build with MAKE1. Since the
source is very small, this has minor impact on performance.

The genver.sh script contains a troll character U+c2a0 (non-break space)
which is refused by some versions of /bin/sh. Patch it away.

Fixes:
    http://autobuild.buildroot.net/results/867/867c74ed74fd04ab06d1a10ff34ca177fe005fd2/
    http://autobuild.buildroot.net/results/f97/f971629bc99147f9014e52c6ef71c3417faa6b67/

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: David Bachelart <david.bachelart@bbright.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sslh/0002-replace-U+c2a0.patch [new file with mode: 0644]
package/sslh/sslh.mk

diff --git a/package/sslh/0002-replace-U+c2a0.patch b/package/sslh/0002-replace-U+c2a0.patch
new file mode 100644 (file)
index 0000000..38093fa
--- /dev/null
@@ -0,0 +1,12 @@
+diff -durN sslh-v1.18.orig/genver.sh sslh-v1.18/genver.sh
+--- sslh-v1.18.orig/genver.sh  2017-02-21 22:03:40.849161283 +0100
++++ sslh-v1.18/genver.sh       2017-02-21 22:03:59.173402356 +0100
+@@ -25,7 +25,7 @@
+         fi
+ fi
+-if [ -d .git ] && head=`git rev-parse --verify HEAD 2>/dev/null`; then
++if [ -d .git ] && head=`git rev-parse --verify HEAD 2>/dev/null`; then
+       # generate the version info based on the tag
+       release=`(git describe --tags || git --describe || git describe --all --long) \
+               2>/dev/null | tr -d '\n'`
index 31774441cab92d18668dec4e23d4721eaebc84d3..17aafd16c21e0dc1ee2122d26c476488724edda7 100644 (file)
@@ -12,7 +12,7 @@ SSLH_LICENSE_FILES = COPYING
 SSLH_DEPENDENCIES = libconfig
 
 define SSLH_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+       $(TARGET_MAKE_ENV) $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D)
 endef
 
 define SSLH_INSTALL_TARGET_CMDS