package/pkg-cmake: disable colouring the output
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 26 Jan 2014 17:37:02 +0000 (18:37 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 28 Jan 2014 22:04:05 +0000 (23:04 +0100)
cmake is the only build-system we support that does colour its output,

Also, since parallel builds generates intermixed output lines, it makes
for ugly-looking output.

Just disable cmake colouring globally.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-cmake.mk

index aedd1fcc477113ca4344728e75f3307494a346d7..13be5570cac9fd3e6d33ea15ac1654afcf0502c3 100644 (file)
@@ -64,6 +64,7 @@ define $(2)_CONFIGURE_CMDS
        $$($$(PKG)_CONF_ENV) $(HOST_DIR)/usr/bin/cmake $$($$(PKG)_SRCDIR) \
                -DCMAKE_TOOLCHAIN_FILE="$$(HOST_DIR)/usr/share/buildroot/toolchainfile.cmake" \
                -DCMAKE_INSTALL_PREFIX="/usr" \
+               -DCMAKE_COLOR_MAKEFILE=OFF \
                -DBUILD_SHARED_LIBS=$(if $(BR2_PREFER_STATIC_LIB),OFF,ON) \
                $$($$(PKG)_CONF_OPT) \
        )