package/python3: add optional support for lzma
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 9 Oct 2016 12:46:16 +0000 (14:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 9 Oct 2016 20:48:42 +0000 (22:48 +0200)
Needed by the upcoming python-mwscrape2slob package.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Thomas: move "select" after "bool".]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/python3/Config.in
package/python3/python3.mk

index 0f4fc88a6ed2c4bb0fd7913ce22492f6c7aae819..bf2cd7c11ec0ec685b3b9cab474db8a712465254 100644 (file)
@@ -98,6 +98,12 @@ config BR2_PACKAGE_PYTHON3_PYEXPAT
        help
          pyexpat and xml libraries for Python3.
 
+config BR2_PACKAGE_PYTHON3_XZ
+       bool "xz module"
+       select BR2_PACKAGE_XZ
+       help
+         xz (a.k.a lzma) module for Python3
+
 config BR2_PACKAGE_PYTHON3_ZLIB
        bool "zlib module"
        select BR2_PACKAGE_ZLIB
index 393b9fb2acc389474523e38e670efc762cd8cd9a..b3f31c0aa0d4de5dfa3b7eb02be8e4e9f18f5919 100644 (file)
@@ -103,6 +103,10 @@ ifeq ($(BR2_PACKAGE_PYTHON3_BZIP2),y)
 PYTHON3_DEPENDENCIES += bzip2
 endif
 
+ifeq ($(BR2_PACKAGE_PYTHON3_XZ),y)
+PYTHON3_DEPENDENCIES += xz
+endif
+
 ifeq ($(BR2_PACKAGE_PYTHON3_ZLIB),y)
 PYTHON3_DEPENDENCIES += zlib
 endif