package/quickjs: new package
authorFrancois Perrad <fperrad@gmail.com>
Fri, 6 Nov 2020 22:51:14 +0000 (23:51 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 7 Nov 2020 12:32:52 +0000 (13:32 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/quickjs/Config.in [new file with mode: 0644]
package/quickjs/quickjs.hash [new file with mode: 0644]
package/quickjs/quickjs.mk [new file with mode: 0644]

index 43cc1b55ae776f4db492dd9cc464746876164f3d..53db631940eddcfc80cb580fc03a54af73730e16 100644 (file)
@@ -922,6 +922,7 @@ F:  package/netsurf/
 F:     package/perl*
 F:     package/pkg-perl.mk
 F:     package/pkg-luarocks.mk
+F:     package/quickjs/
 F:     package/rings/
 F:     package/tekui/
 F:     package/wpebackend-fdo/
index 016a99ed1a7b7d5ed846ad79d59a1de8ca16ffe3..8fcea06433e0ff14928dbff692e654468f375513 100644 (file)
@@ -1245,6 +1245,7 @@ menu "External python modules"
        source "package/python-zope-interface/Config.in"
 endmenu
 endif
+       source "package/quickjs/Config.in"
        source "package/ruby/Config.in"
        source "package/tcl/Config.in"
 if BR2_PACKAGE_TCL
diff --git a/package/quickjs/Config.in b/package/quickjs/Config.in
new file mode 100644 (file)
index 0000000..ee53744
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_QUICKJS
+       bool "quickjs"
+       depends on !BR2_STATIC_LIBS
+       # No way to check for fenv support.
+       depends on !BR2_TOOLCHAIN_USES_UCLIBC
+       depends on BR2_USE_MMU # fork()
+       help
+         QuickJS is a small and embeddable Javascript engine.
+         It supports the ES2020 specification including modules,
+         asynchronous generators, proxies and BigInt.
+
+         https://bellard.org/quickjs/
+
+comment "quickjs needs a glibc or musl toolchain w/ dynamic library"
+       depends on BR2_USE_MMU
+       depends on BR2_STATIC_LIBS || BR2_TOOLCHAIN_USES_UCLIBC
diff --git a/package/quickjs/quickjs.hash b/package/quickjs/quickjs.hash
new file mode 100644 (file)
index 0000000..076e4bd
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256  0021a3e8cdc6b61e225411d05e2841d2437e1ccf4b4cabb9a5f7685ebfb57717  quickjs-2020-09-06.tar.xz
diff --git a/package/quickjs/quickjs.mk b/package/quickjs/quickjs.mk
new file mode 100644 (file)
index 0000000..557ffb1
--- /dev/null
@@ -0,0 +1,37 @@
+################################################################################
+#
+# quickjs
+#
+################################################################################
+
+QUICKJS_VERSION = 2020-09-06
+QUICKJS_SOURCE = quickjs-$(QUICKJS_VERSION).tar.xz
+QUICKJS_SITE = https://bellard.org/quickjs
+QUICKJS_LICENSE = MIT
+QUICKJS_INSTALL_STAGING = YES
+
+define QUICKJS_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+               CROSS_PREFIX="$(TARGET_CROSS)" \
+               all
+endef
+
+define QUICKJS_INSTALL_STAGING_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+               CROSS_PREFIX="$(TARGET_CROSS)" \
+               DESTDIR=$(STAGING_DIR) \
+               STRIP=/bin/true \
+               prefix=/usr \
+               install
+endef
+
+define QUICKJS_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+               CROSS_PREFIX="$(TARGET_CROSS)" \
+               DESTDIR=$(TARGET_DIR) \
+               STRIP=/bin/true \
+               prefix=/usr \
+               install
+endef
+
+$(eval $(generic-package))