package: Add rrdtool package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 23 Jun 2010 20:22:16 +0000 (17:22 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 8 Oct 2010 07:20:57 +0000 (09:20 +0200)
[Peter: use hook to remove examples]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/Config.in
package/rrdtool/Config.in [new file with mode: 0644]
package/rrdtool/rrdtool.mk [new file with mode: 0644]

diff --git a/CHANGES b/CHANGES
index 41406b8fea5f8c623b3d29241fc5f18c19e80c39..3cf4a0f91d4870ac6d31b793b3aaa5be8c8b7cda 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -21,7 +21,7 @@
 
        Alpha, Cris, IA64 and Sparc64 architecture support removed.
 
-       New packages: gst-ffmpeg, libmpeg2, librsvg, xz
+       New packages: gst-ffmpeg, libmpeg2, librsvg, rrdtool, xz
 
        Updated/fixed packages: acpid, alsa-lib, argus, at, autoconf,
        automake, avahi, axel, beecrypt, berkeleydb, bind, bmon, boa,
index 5e08d59574dfcb515af4dde21edaed2e8da624c0..3b6cd19c31ac4499cf5ecc1837564227e6e231bd 100644 (file)
@@ -85,6 +85,9 @@ endmenu
 
 menu "Graphic libraries and applications (graphic/text)"
 
+comment "Graphic applications"
+source "package/rrdtool/Config.in"
+
 comment "graphic libraries"
 source "package/directfb/Config.in"
 source "package/directfb-examples/Config.in"
diff --git a/package/rrdtool/Config.in b/package/rrdtool/Config.in
new file mode 100644 (file)
index 0000000..d315b57
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_RRDTOOL
+       bool "rrdtool"
+       depends on BR2_USE_WCHAR
+       select BR2_PACKAGE_FREETYPE
+       select BR2_PACKAGE_LIBART
+       select BR2_PACKAGE_LIBPNG
+       select BR2_PACKAGE_ZLIB
+       help
+         RRDtool is the OpenSource industry standard, high performance
+         data logging and graphing system for time series data.
+
+         http://oss.oetiker.ch/rrdtool/
+
+comment "rrdtool requires a toolchain with WCHAR support"
+       depends on !BR2_USE_WCHAR
diff --git a/package/rrdtool/rrdtool.mk b/package/rrdtool/rrdtool.mk
new file mode 100644 (file)
index 0000000..80789c6
--- /dev/null
@@ -0,0 +1,28 @@
+#############################################################
+#
+# rrdtool
+#
+#############################################################
+
+RRDTOOL_VERSION = 1.2.30
+RRDTOOL_SITE = http://oss.oetiker.ch/rrdtool/pub
+RRDTOOL_DEPENDENCIES = host-pkg-config freetype libart libpng zlib
+RRDTOOL_INSTALL_STAGING = YES
+RRDTOOL_CONF_ENV = rd_cv_ieee_works=yes rd_cv_null_realloc=nope \
+                       ac_cv_func_mmap_fixed_mapped=yes
+RRDTOOL_CONF_OPT = --disable-perl --disable-python --disable-ruby \
+                       --disable-tcl --program-transform-name=''
+
+define RRDTOOL_REMOVE_EXAMPLES
+       rm -rf $(TARGET_DIR)/usr/share/rrdtool/examples
+endef
+
+RRDTOOL_POST_INSTALL_TARGET_HOOKS += RRDTOOL_REMOVE_EXAMPLES
+
+define RRDTOOL_UNINSTALL_TARGET_CMDS
+       $(MAKE) DESTDIR=$(TARGET_DIR) -C $(@D) uninstall
+       rm -rf $(TARGET_DIR)/usr/share/rrdtool
+       rm -f $(TARGET_DIR)/usr/lib/librrd*
+endef
+
+$(eval $(call AUTOTARGETS,package,rrdtool))