package/libnpth: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Mar 2017 11:33:25 +0000 (12:33 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Mar 2017 20:27:42 +0000 (21:27 +0100)
Needed for gnupg 2.1.x
https://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git;a=commitdiff;h=001352077cdc7e402421c77328bea1a052005673

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/libnpth/Config.in [new file with mode: 0644]
package/libnpth/libnpth.hash [new file with mode: 0644]
package/libnpth/libnpth.mk [new file with mode: 0644]

index bdc93d9aad6293cc58697d291e9f3c3117771482..ad30895399680d9d5ce5f5f2d40b7badc24806c1 100644 (file)
@@ -196,6 +196,7 @@ F:  package/libldns/
 F:     package/libmicrohttpd/
 F:     package/libminiupnpc/
 F:     package/libnatpmp/
+F:     package/libnpth/
 F:     package/libogg/
 F:     package/libopenh264/
 F:     package/libpciaccess/
index 66c87d558676694fbce17cfc8e8d9e0acbb42786..9f4b550207f98212a5e0326442ee9d60e281210e 100644 (file)
@@ -1365,6 +1365,7 @@ menu "Other"
        source "package/libical/Config.in"
        source "package/libite/Config.in"
        source "package/liblinear/Config.in"
+       source "package/libnpth/Config.in"
        source "package/libnspr/Config.in"
        source "package/libpfm4/Config.in"
        source "package/libplatform/Config.in"
diff --git a/package/libnpth/Config.in b/package/libnpth/Config.in
new file mode 100644 (file)
index 0000000..71f9fcb
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_LIBNPTH
+       bool "libnpth"
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU # fork()
+       help
+         nPth is a library to provide the GNU Pth API and thus a
+         non-preemptive threads implementation.
+
+         https://www.gnupg.org/related_software/npth/index.html
+
+comment "libnpth needs a toolchain w/ threads support"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_USE_MMU
diff --git a/package/libnpth/libnpth.hash b/package/libnpth/libnpth.hash
new file mode 100644 (file)
index 0000000..d8d0fbd
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 bca81940436aed0734eb8d0ff8b179e04cc8c087f5625204419f5f45d736a82a  npth-1.3.tar.bz2
diff --git a/package/libnpth/libnpth.mk b/package/libnpth/libnpth.mk
new file mode 100644 (file)
index 0000000..c97099b
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# libnpth
+#
+################################################################################
+
+LIBNPTH_VERSION = 1.3
+LIBNPTH_SOURCE = npth-$(LIBNPTH_VERSION).tar.bz2
+LIBNPTH_SITE = ftp://ftp.gnupg.org/gcrypt/npth
+LIBNPTH_LICENSE = LGPLv3+ or GPLv2+
+LIBNPTH_LICENSE_FILES = COPYING COPYING.LESSER
+LIBNPTH_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))