ncurses: speed up the build by not installing manpages
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 24 Feb 2013 07:27:50 +0000 (07:27 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 4 Mar 2013 20:18:50 +0000 (21:18 +0100)
The installation of manpages during the installation step of
host-ncurses and ncurses is horribly slow, and useless. This commit
therefore disables the installation of those manpages, using the
--without-manpages configuration option.

It brings the combined host-ncurses+ncurses configure/build/install
time from 3 minutes and 18 seconds to 1 minute and 36 seconds.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/ncurses/ncurses.mk

index aa2b6bc04e66ec65e9e3a6e947b82c6375fd3d63..e77a0f1afb93fac7364d070a8aa567646e9ffc3f 100644 (file)
@@ -27,7 +27,8 @@ NCURSES_CONF_OPT = \
        --enable-echo \
        --enable-const \
        --enable-overwrite \
-       --enable-pc-files
+       --enable-pc-files \
+       $(if $(BR2_HAVE_DOCUMENTATION),,--without-manpages)
 
 ifneq ($(BR2_ENABLE_DEBUG),y)
 NCURSES_CONF_OPT += --without-debug
@@ -115,7 +116,8 @@ define HOST_NCURSES_BUILD_CMDS
 endef
 
 HOST_NCURSES_CONF_OPT = \
-       --without-shared --without-gpm
+       --without-shared --without-gpm \
+       --without-manpages
 
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))