gst1-plugins-bad: add sbc support
authorMarcin Nowakowski <marcin.nowakowski@imgtec.com>
Thu, 19 May 2016 18:01:35 +0000 (20:01 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 19 May 2016 19:15:45 +0000 (21:15 +0200)
Signed-off-by: Marcin Nowakowski <marcin.nowakowski@imgtec.com>
Reviewed-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index c4c4e434939f19ef3ca796a9e22f9ad97f9d2cee..046c2aabd216b7443df37451c779dbd65253024b 100644 (file)
@@ -638,6 +638,10 @@ comment "rsvg plugin needs a toolchain w/ C++"
        depends on !BR2_INSTALL_LIBSTDCPP
        depends on BR2_TOOLCHAIN_HAS_SYNC_4
 
+config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SBC
+       bool "sbc"
+       select BR2_PACKAGE_SBC
+
 config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDL
        bool "sdl"
        select BR2_PACKAGE_SDL
index c3c4682bcec321b5916a8ef175488ca4757a1fec..8ddf5d9232c272d8ea9ccc819498362e6c54792c 100644 (file)
@@ -71,7 +71,6 @@ GST1_PLUGINS_BAD_CONF_OPTS += \
        --disable-gme \
        --disable-xvid \
        --disable-vdpau \
-       --disable-sbc \
        --disable-schro \
        --disable-zbar \
        --disable-rtmp \
@@ -743,6 +742,13 @@ else
 GST1_PLUGINS_BAD_CONF_OPTS += --disable-rsvg
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SBC),y)
+GST1_PLUGINS_BAD_CONF_OPTS += --enable-sbc
+GST1_PLUGINS_BAD_DEPENDENCIES += sbc
+else
+GST1_PLUGINS_BAD_CONF_OPTS += --disable-sbc
+endif
+
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_SDL),y)
 GST1_PLUGINS_BAD_CONF_ENV += ac_cv_path_SDL_CONFIG=$(STAGING_DIR)/usr/bin/sdl-config
 GST1_PLUGINS_BAD_CONF_OPTS += --enable-sdl