boot/grub: use install instead of cp
authorGuido Martínez <guido@vanguardiasur.com.ar>
Fri, 21 Nov 2014 16:19:07 +0000 (13:19 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 22 Nov 2014 18:01:12 +0000 (19:01 +0100)
This way we don't depend on the permissions of files under boot/grub/,
which aren't tracked.

While we're at it, change all 'cp' usages into 'install' with the
correct mode for each file.

Signed-off-by: Guido Martínez <guido@vanguardiasur.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/grub/grub.mk

index 535ada637d2f60a6b89615161408f9b0fdfff6f3..ae687d6b183860a52a8d6f1f16dfaab88849d50b 100644 (file)
@@ -81,7 +81,7 @@ GRUB_CONF_OPTS = \
 
 ifeq ($(BR2_TARGET_GRUB_SPLASH),y)
 define GRUB_INSTALL_SPLASH
-       cp boot/grub/splash.xpm.gz $(TARGET_DIR)/boot/grub/
+       $(INSTALL) -D -m 0644 boot/grub/splash.xpm.gz $(TARGET_DIR)/boot/grub/splash.xpm.gz
 endef
 else
 define GRUB_INSTALL_SPLASH
@@ -95,14 +95,14 @@ endif
 # of a disk or disk image.
 
 define GRUB_INSTALL_TARGET_CMDS
-       install -m 0755 -D $(@D)/grub/grub $(HOST_DIR)/sbin/grub
-       mkdir -p $(TARGET_DIR)/boot/grub
-       cp $(@D)/stage1/stage1 $(TARGET_DIR)/boot/grub
+       $(INSTALL) -D -m 0755 $(@D)/grub/grub $(HOST_DIR)/sbin/grub
+       $(INSTALL) -D -m 0755 $(@D)/stage1/stage1 $(TARGET_DIR)/boot/grub/stage1
        for f in $(GRUB_STAGE_1_5_TO_INSTALL) ; do \
-               cp $(@D)/stage2/$${f}_stage1_5 $(TARGET_DIR)/boot/grub ; \
+               $(INSTALL) -D -m 0755 $(@D)/stage2/$${f}_stage1_5 \
+                       $(TARGET_DIR)/boot/grub/$${f}_stage1_5 ; \
        done
-       cp $(@D)/stage2/stage2 $(TARGET_DIR)/boot/grub
-       cp boot/grub/menu.lst $(TARGET_DIR)/boot/grub
+       $(INSTALL) -D -m 0644 $(@D)/stage2/stage2 $(TARGET_DIR)/boot/grub/stage2
+       $(INSTALL) -D -m 0644 boot/grub/menu.lst $(TARGET_DIR)/boot/grub/menu.lst
        $(GRUB_INSTALL_SPLASH)
 endef