package/libsoundtouch: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 11 Aug 2015 18:16:54 +0000 (20:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Aug 2015 12:49:52 +0000 (14:49 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libsoundtouch/Config.in [new file with mode: 0644]
package/libsoundtouch/libsoundtouch.mk [new file with mode: 0644]

index 958b3ed1246647a4c74b9a73c5fb66df4e6d6310..72fcbc92b57d68602d0d59e1d504504adfd999dc 100644 (file)
@@ -713,6 +713,7 @@ menu "Audio/Sound"
        source "package/libsidplay2/Config.in"
        source "package/libsilk/Config.in"
        source "package/libsndfile/Config.in"
+       source "package/libsoundtouch/Config.in"
        source "package/libsoxr/Config.in"
        source "package/libvorbis/Config.in"
        source "package/mp4v2/Config.in"
diff --git a/package/libsoundtouch/Config.in b/package/libsoundtouch/Config.in
new file mode 100644 (file)
index 0000000..396036f
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LIBSOUNDTOUCH
+       bool "libsoundtouch"
+       help
+         SoundTouch is an open-source audio processing library for
+         changing the Tempo, Pitch and Playback Rates of audio streams
+         or audio files.
+
+         http://www.surina.net/soundtouch
diff --git a/package/libsoundtouch/libsoundtouch.mk b/package/libsoundtouch/libsoundtouch.mk
new file mode 100644 (file)
index 0000000..cdfec20
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# libsoundtouch
+#
+################################################################################
+
+LIBSOUNDTOUCH_VERSION = 010a91a59071c7fefd316fca62c0d980ec85b4b1
+LIBSOUNDTOUCH_SITE = https://freeswitch.org/stash/scm/sd/libsoundtouch.git
+LIBSOUNDTOUCH_SITE_METHOD = git
+LIBSOUNDTOUCH_LICENSE = LGPLv2.1+
+LIBSOUNDTOUCH_LICENSE_FILES = COPYING.TXT
+LIBSOUNDTOUCH_AUTORECONF = YES
+LIBSOUNDTOUCH_INSTALL_STAGING = YES
+
+define LIBSOUNDTOUCH_CREATE_CONFIG_M4
+       mkdir -p $(@D)/config/m4
+endef
+LIBSOUNDTOUCH_POST_PATCH_HOOKS += LIBSOUNDTOUCH_CREATE_CONFIG_M4
+
+$(eval $(autotools-package))