package/keyutils: disable static library for shared only build
authorRomain Naour <romain.naour@openwide.fr>
Sat, 27 Dec 2014 21:58:22 +0000 (22:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 2 Jan 2015 11:39:18 +0000 (12:39 +0100)
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/keyutils/keyutils.mk

index 2038c0dd844e4a46f5f5cf60ca3bfde881e86ce6..36588e6c377491db6feb2cb59f5a685551f7d957 100644 (file)
@@ -23,6 +23,10 @@ ifeq ($(BR2_STATIC_LIBS),y)
 KEYUTILS_MAKE_PARAMS += NO_SOLIB=1
 endif
 
+ifeq ($(BR2_SHARED_LIBS),y)
+KEYUTILS_MAKE_PARAMS += NO_ARLIB=1
+endif
+
 define KEYUTILS_BUILD_CMDS
        $(TARGET_CONFIGURE_OPTS) $(MAKE) $(KEYUTILS_MAKE_PARAMS) -C $(@D)
 endef