arc: Add support for ARC-specific uClibc
authorMischa Jonker <mischa.jonker@synopsys.com>
Thu, 2 May 2013 09:51:28 +0000 (09:51 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 4 May 2013 21:21:19 +0000 (23:21 +0200)
[Peter: fix whitespace]
Signed-off-by: Mischa Jonker <mjonker@synopsys.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/uClibc/Config.in
toolchain/uClibc/uClibc-snapshot.config
toolchain/uClibc/uclibc.mk

index b98e2e8682b2225bc40e4435ddad4f64bc741fbf..94e8169f3cafb685984e7ccc14e977e1c8c9e913 100644 (file)
@@ -16,11 +16,15 @@ choice
 
        config BR2_UCLIBC_VERSION_0_9_32
                bool "uClibc 0.9.32.x"
-               depends on !(BR2_avr32 || BR2_sh || BR2_xtensa)
+               depends on !(BR2_arc || BR2_avr32 || BR2_sh || BR2_xtensa)
 
        config BR2_UCLIBC_VERSION_0_9_33
                bool "uClibc 0.9.33.x"
-               depends on !BR2_xtensa
+               depends on !(BR2_arc || BR2_xtensa)
+
+       config BR2_UCLIBC_VERSION_0_9_33_ARC
+               bool "uClibc 0.9.33.x-arc"
+               depends on BR2_arc
 
        config BR2_UCLIBC_VERSION_SNAPSHOT
                bool "daily snapshot"
@@ -39,6 +43,7 @@ config BR2_UCLIBC_VERSION_STRING
        default 0.9.31.1        if BR2_UCLIBC_VERSION_0_9_31
        default 0.9.32.1        if BR2_UCLIBC_VERSION_0_9_32
        default 0.9.33.2        if BR2_UCLIBC_VERSION_0_9_33
+       default 0.9.33-arc      if BR2_UCLIBC_VERSION_0_9_33_ARC
        default $BR2_USE_UCLIBC_SNAPSHOT        if BR2_UCLIBC_VERSION_SNAPSHOT
 
 config BR2_UCLIBC_CONFIG
@@ -46,6 +51,7 @@ config BR2_UCLIBC_CONFIG
        default "toolchain/uClibc/uClibc-0.9.31.config" if BR2_UCLIBC_VERSION_0_9_31
        default "toolchain/uClibc/uClibc-0.9.32.config" if BR2_UCLIBC_VERSION_0_9_32
        default "toolchain/uClibc/uClibc-0.9.33.config" if BR2_UCLIBC_VERSION_0_9_33
+       default "toolchain/uClibc/uClibc-snapshot.config" if BR2_UCLIBC_VERSION_0_9_33_ARC
        default "toolchain/uClibc/uClibc-snapshot.config" if BR2_UCLIBC_VERSION_SNAPSHOT
        help
          Some people may wish to use their own modified uClibc configuration
index 71fa4720e5bbf087ec88b63311879957e9c97dfe..cb6258d83d4c181faeb6729add9d18c60b49d4b3 100644 (file)
@@ -4,6 +4,7 @@
 # Fri Jul  9 22:31:59 2010
 #
 # TARGET_alpha is not set
+# TARGET_arc is not set
 # TARGET_arm is not set
 # TARGET_avr32 is not set
 # TARGET_bfin is not set
@@ -16,6 +17,7 @@
 # TARGET_i960 is not set
 # TARGET_ia64 is not set
 # TARGET_m68k is not set
+# TARGET_metag is not set
 # TARGET_microblaze is not set
 # TARGET_mips is not set
 # TARGET_nios is not set
index 2249651b749e105efd285181d6ca3820e3139a4e..1629e7625c5637eeca77e9a1dddea7a239ca8fa9 100644 (file)
@@ -17,6 +17,9 @@ UCLIBC_VERSION:=$(call qstrip,$(BR2_UCLIBC_VERSION_STRING))
 ifeq ($(BR2_UCLIBC_VERSION_SNAPSHOT),y)
 UCLIBC_SITE:=http://www.uclibc.org/downloads/snapshots
 UCLIBC_DIR:=$(TOOLCHAIN_DIR)/uClibc
+else ifeq ($(findstring arc,$(UCLIBC_VERSION)),arc)
+UCLIBC_SITE:=$(BR2_ARC_SITE)
+UCLIBC_DIR:=$(TOOLCHAIN_DIR)/uClibc-$(UCLIBC_VERSION)
 else
 UCLIBC_SITE:=http://www.uclibc.org/downloads
 UCLIBC_DIR:=$(TOOLCHAIN_DIR)/uClibc-$(UCLIBC_VERSION)
@@ -31,6 +34,7 @@ UCLIBC_TARGET_ARCH:=$(shell $(SHELL) -c "echo $(ARCH) | sed \
                -e 's/-.*//' \
                -e 's/i.86/i386/' \
                -e 's/sparc.*/sparc/' \
+               -e 's/arc.*/arc/g' \
                -e 's/arm.*/arm/g' \
                -e 's/m68k.*/m68k/' \
                -e 's/ppc/powerpc/g' \