dhcpcd: bump to version 6.4.0
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 17 Jun 2014 22:07:46 +0000 (19:07 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 18 Jun 2014 11:58:21 +0000 (13:58 +0200)
Now with support for static builds.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dhcpcd/Config.in
package/dhcpcd/dhcpcd.mk

index 68eac1ca864a5375c9ed84c2335c31843f3d2e9d..79063eff42a44f9c44ef714b7e33373c39c597ab 100644 (file)
@@ -1,15 +1,8 @@
 config BR2_PACKAGE_DHCPCD
        bool "dhcpcd"
        # No support for AI_ADDRCONFIG
-       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 && \
-               !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R1
-       depends on !BR2_PREFER_STATIC_LIB
+       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2
        help
          An RFC2131 compliant DHCP client
 
          http://roy.marples.name/downloads/dhcpcd
-
-comment "dhcpcd needs a toolchain w/ dynamic library"
-       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 && \
-               !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R1
-       depends on BR2_PREFER_STATIC_LIB
index 01ced3af59939fd8640608ea1eb15ce20c98ecad..7a16f52d3513de99d8c5d94b94b1d9237c9bc71b 100644 (file)
@@ -4,15 +4,20 @@
 #
 ################################################################################
 
-DHCPCD_VERSION = 6.1.0
+DHCPCD_VERSION = 6.4.0
 DHCPCD_SOURCE = dhcpcd-$(DHCPCD_VERSION).tar.bz2
 DHCPCD_SITE = http://roy.marples.name/downloads/dhcpcd
+DHCPCD_DEPENDENCIES = host-pkgconf
 DHCPCD_LICENSE = BSD-2c
 
 ifeq ($(BR2_INET_IPV6),)
        DHCPCD_CONFIG_OPT += --disable-ipv6
 endif
 
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+       DHCPCD_CONFIG_OPT += --enable-static
+endif
+
 ifeq ($(BR2_USE_MMU),)
        DHCPCD_CONFIG_OPT += --disable-fork
 endif