libev: don't install event.h
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 26 Aug 2014 11:36:17 +0000 (08:36 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 26 Aug 2014 21:49:18 +0000 (23:49 +0200)
It's a 'compatibility layer' with libevent which we:
1) Don't need
2) Possibly outdated with respect to libevent2
3) Causes build failures

Fixes:
http://autobuild.buildroot.net/results/451/4510fe02ef3497803ed27bf339dca07b3b073c10/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libev/libev.mk

index a6ff3a92cb4f3d2daa364cd57a3f7f02fc6eef1a..dc428583fcbb6a7601f7d2dc08a4de402aec9514 100644 (file)
@@ -10,4 +10,11 @@ LIBEV_INSTALL_STAGING = YES
 LIBEV_LICENSE = BSD-2c or GPLv2+
 LIBEV_LICENSE_FILES = LICENSE
 
+# The 'compatibility' event.h header conflicts with libevent
+# It's completely unnecessary for BR packages so remove it
+define LIBEV_DISABLE_EVENT_H_INSTALL
+       $(SED) 's/ event.h//' $(@D)/Makefile.in
+endef
+LIBEV_POST_PATCH_HOOKS += LIBEV_DISABLE_EVENT_H_INSTALL
+
 $(eval $(autotools-package))