package/python: security bump version to 2.7.13
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 22 Dec 2016 06:46:00 +0000 (07:46 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 22 Dec 2016 09:27:31 +0000 (10:27 +0100)
Rebased patches 004 & 010.

Changelog:
https://hg.python.org/cpython/raw-file/v2.7.13/Misc/NEWS

Fixes CVE-2016-2183 & CVE-2016-1000110.

This bump also fixes the host build with openssl 1.1.0,
http://patchwork.ozlabs.org/patch/696139/ is not needed anymore.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/python/004-sysconfigdata-install-location.patch
package/python/010-fix-python-config.patch
package/python/python.hash
package/python/python.mk

index edf7120e12241fa43586be07110d7bf0908e9678..2998364fbfa3397b8fb7b643a59c55d8a2f25813 100644 (file)
@@ -58,9 +58,9 @@ Index: b/Makefile.pre.in
        -rm -f python*-gdb.py
 -      -rm -f pybuilddir.txt
 +      -rm -f pybuilddir.txt pysysconfigdatadir.txt
-       find $(srcdir)/[a-zA-Z]* '(' -name '*.fdc' -o -name '*~' \
-                                    -o -name '[@,#]*' -o -name '*.old' \
-                                    -o -name '*.orig' -o -name '*.rej' \
+       # Issue #28258: set LC_ALL to avoid issues with Estonian locale.
+       # Expansion is performed here by shell (spawned by make) itself before
+       # arguments are passed to find. So LC_ALL=C must be set as a separate
 Index: b/configure.ac
 ===================================================================
 --- a/configure.ac
index 1266f3d3af0b15a62440fca584a379f71d0773a1..b40339b42da21c4e49523059d8d1ce91ec76c1ed 100644 (file)
@@ -61,7 +61,7 @@ Index: b/Makefile.pre.in
 @@ -410,7 +410,7 @@
  
  # Default target
- all:          build_all
+ all:          @DEF_MAKE_ALL_RULE@
 -build_all:    $(BUILDPYTHON) oldsharedmods sharedmods gdbhooks
 +build_all:    $(BUILDPYTHON) oldsharedmods sharedmods gdbhooks python-config
  
index b7d00360087384fc867021bb4ad7d9fc431ef1ac..f285e4243f150f8c54a5e45544d43a3d640d2631 100644 (file)
@@ -1,4 +1,4 @@
-# From https://www.python.org/downloads/release/python-2712/
-md5    57dffcee9cee8bb2ab5f82af1d8e9a69        Python-2.7.12.tar.xz
+# From https://www.python.org/downloads/release/python-2713/
+md5 53b43534153bb2a0363f08bae8b9d990  Python-2.7.13.tar.xz
 # Locally calculated
-sha256 d7837121dd5652a05fef807c361909d255d173280c4e1a4ded94d73d80a1f978  Python-2.7.12.tar.xz
+sha256 35d543986882f78261f97787fd3e06274bfa6df29fac9b4a94f73930ff98f731  Python-2.7.13.tar.xz
index cfd5a0af12ffb8d62bf308a950cf35056e349c98..7b20434c94c2b8b80964e8ce76a7e5351898c584 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 PYTHON_VERSION_MAJOR = 2.7
-PYTHON_VERSION = $(PYTHON_VERSION_MAJOR).12
+PYTHON_VERSION = $(PYTHON_VERSION_MAJOR).13
 PYTHON_SOURCE = Python-$(PYTHON_VERSION).tar.xz
 PYTHON_SITE = http://python.org/ftp/python/$(PYTHON_VERSION)
 PYTHON_LICENSE = Python software foundation license v2, others