pkg-infra: warn about use of deprecated GENTARGETS
authorArnout Vandecappelle <arnout@mind.be>
Tue, 28 Aug 2012 14:37:00 +0000 (14:37 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 5 Sep 2012 20:54:20 +0000 (22:54 +0200)
With the replacement of GENTARGETS by package-generic, there is a risk
that local packages don't work anymore without any indication of what
is wrong.  Therefore, generate an error message if the GENTARGETS,
AUTOTARGETS or CMAKETARGETS macro is still used.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.in

index 340e3879948a437ac20eeea3387ec4853ba38fce..64508b28389ed726d84f2764bdfe05992a5d3e27 100644 (file)
@@ -300,6 +300,12 @@ else
 SHARED_STATIC_LIBS_OPTS=--enable-static --enable-shared
 endif
 
+# Warn if a package uses the deprecated GENTARGETS macros.  This can be
+# removed again for BR-2012.11.
+GENTARGETS = $$(error The GENTARGETS macro no longer exists; use $$$$(eval $$$$(generic-package)) or $$$$(eval $$$$(host-generic-package)))
+AUTOTARGETS = $$(error The AUTOTARGETS macro no longer exists; use $$$$(eval $$$$(autotools-package)) or $$$$(eval $$$$(host-autotools-package)))
+CMAKETARGETS = $$(error The CMAKETARGETS macro no longer exists; use $$$$(eval $$$$(cmake-package)) or $$$$(eval $$$$(host-cmake-package)))
+
 include package/pkg-utils.mk
 include package/pkg-download.mk
 include package/pkg-autotools.mk