package/uftrace: fix build on i386
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 24 Apr 2021 16:08:57 +0000 (18:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 24 Apr 2021 16:09:55 +0000 (18:09 +0200)
The --arch value on i386 must be "i386", and not i486, i586 or i686,
so let's have a special case for BR2_i386, and use $(BR2_ARCH) for the
other supported CPU architectures.

Fixes:

  http://autobuild.buildroot.net/results/01a28789bcec9af66137cbce5a8fda2d606de99f/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/uftrace/uftrace.mk

index f42bbbddaa1729b01a046dad30860410ceb44a09..7c9b9b1992cd4c66fcd5ad9058ad42206d105cef 100644 (file)
@@ -15,6 +15,12 @@ UFTRACE_CONFIGURE_OPTS = \
        --without-libncurses \
        --without-capstone
 
+ifeq ($(BR2_i386),y)
+UFTRACE_ARCH = i386
+else
+UFTRACE_ARCH = $(BR2_ARCH)
+endif
+
 # Only --without-<foo> options are supported.
 ifeq ($(BR2_PACKAGE_ELFUTILS),y)
 UFTRACE_DEPENDENCIES += elfutils
@@ -37,7 +43,7 @@ define UFTRACE_CONFIGURE_CMDS
        (cd $(@D); $(TARGET_CONFIGURE_OPTS) \
                LDFLAGS="$(UFTRACE_LDFLAGS)" \
                ./configure \
-               --arch=$(BR2_ARCH) \
+               --arch=$(UFTRACE_ARCH) \
                --prefix=/usr \
                $(UFTRACE_CONFIGURE_OPTS) \
                -o $(@D)/.config)