Fix the computation of REAL_GNU_TARGET_NAME
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 6 May 2010 18:44:21 +0000 (20:44 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 6 May 2010 21:08:37 +0000 (23:08 +0200)
When the selected C library is glibc, the C library shouldn't be
mentionned in REAL_GNU_TARGET_NAME. In other words:

 arm-unknown-linux-uclibcgnueabi must be used for uClibc
 arm-unknown-linux-gnueabi must be used for glibc

This fixes the build of GDB on the target, as reported by Quotient
Remainder <quotientvremainder@gmail.com>.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.in

index eab9168707cfabb9742f525e55dedc50ed0c1c52..cd492f1fd5087f9e0fab07f3c50cb4f65b7c23a2 100644 (file)
@@ -104,7 +104,7 @@ LIBC=uclibc
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_UCLIBC),y)
 LIBC=uclibc
 else
-LIBC=glibc
+LIBC=
 endif
 
 ifeq ($(BR2_ARM_EABI),y)