qt5base: rename patch to avoid conflict on 0002
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 15 May 2015 18:23:52 +0000 (20:23 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 16 May 2015 13:13:58 +0000 (15:13 +0200)
There are currently two patches with the 0002 sequence number, which
isn't great. Rename one of them to use the 0003 sequence number.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qt5/qt5base/0002-mkspecs-files.patch [deleted file]
package/qt5/qt5base/0003-mkspecs-files.patch [new file with mode: 0644]

diff --git a/package/qt5/qt5base/0002-mkspecs-files.patch b/package/qt5/qt5base/0002-mkspecs-files.patch
deleted file mode 100644 (file)
index 09c1b67..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-Add a Buildroot 'device' to ease cross-compilation
-
-Qt5 has a mechanism to support "device" profiles, so that people can
-specify the compiler, compiler flags and so on for a specific device.
-
-We leverage this mechanism in the Buildroot packaging of qt5 to
-simplify cross-compilation: we have our own "device" definition, which
-allows us to easily pass the cross-compiler paths and flags from our
-qt5.mk.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
-Index: b/mkspecs/devices/linux-buildroot-g++/qmake.conf
-===================================================================
---- /dev/null
-+++ b/mkspecs/devices/linux-buildroot-g++/qmake.conf
-@@ -0,0 +1,16 @@
-+include(../common/linux_device_pre.conf)
-+
-+# modifications to g++-unix.conf
-+QMAKE_CC                = $${BR_CCACHE} $${CROSS_COMPILE}gcc
-+QMAKE_CXX               = $${BR_CCACHE} $${CROSS_COMPILE}g++
-+
-+#modifications to gcc-base.conf
-+QMAKE_CFLAGS           += $${BR_COMPILER_CFLAGS}
-+QMAKE_CXXFLAGS         += $${BR_COMPILER_CXXFLAGS}
-+QMAKE_CXXFLAGS_RELEASE += -O3
-+CONFIG                 += nostrip
-+
-+QMAKE_LIBS             += -lrt -lpthread -ldl
-+
-+include(../common/linux_device_post.conf)
-+load(qt_config)
-Index: b/mkspecs/devices/linux-buildroot-g++/qplatformdefs.h
-===================================================================
---- /dev/null
-+++ b/mkspecs/devices/linux-buildroot-g++/qplatformdefs.h
-@@ -0,0 +1 @@
-+#include "../../linux-g++/qplatformdefs.h"
diff --git a/package/qt5/qt5base/0003-mkspecs-files.patch b/package/qt5/qt5base/0003-mkspecs-files.patch
new file mode 100644 (file)
index 0000000..09c1b67
--- /dev/null
@@ -0,0 +1,39 @@
+Add a Buildroot 'device' to ease cross-compilation
+
+Qt5 has a mechanism to support "device" profiles, so that people can
+specify the compiler, compiler flags and so on for a specific device.
+
+We leverage this mechanism in the Buildroot packaging of qt5 to
+simplify cross-compilation: we have our own "device" definition, which
+allows us to easily pass the cross-compiler paths and flags from our
+qt5.mk.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/mkspecs/devices/linux-buildroot-g++/qmake.conf
+===================================================================
+--- /dev/null
++++ b/mkspecs/devices/linux-buildroot-g++/qmake.conf
+@@ -0,0 +1,16 @@
++include(../common/linux_device_pre.conf)
++
++# modifications to g++-unix.conf
++QMAKE_CC                = $${BR_CCACHE} $${CROSS_COMPILE}gcc
++QMAKE_CXX               = $${BR_CCACHE} $${CROSS_COMPILE}g++
++
++#modifications to gcc-base.conf
++QMAKE_CFLAGS           += $${BR_COMPILER_CFLAGS}
++QMAKE_CXXFLAGS         += $${BR_COMPILER_CXXFLAGS}
++QMAKE_CXXFLAGS_RELEASE += -O3
++CONFIG                 += nostrip
++
++QMAKE_LIBS             += -lrt -lpthread -ldl
++
++include(../common/linux_device_post.conf)
++load(qt_config)
+Index: b/mkspecs/devices/linux-buildroot-g++/qplatformdefs.h
+===================================================================
+--- /dev/null
++++ b/mkspecs/devices/linux-buildroot-g++/qplatformdefs.h
+@@ -0,0 +1 @@
++#include "../../linux-g++/qplatformdefs.h"