qt5: fix legal info
authorFatih Aşıcı <fatih.asici@gmail.com>
Fri, 13 Jun 2014 13:38:12 +0000 (16:38 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 14 Jun 2014 16:52:44 +0000 (18:52 +0200)
Signed-off-by: Fatih Aşıcı <fatih.asici@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt5/qt5graphicaleffects/qt5graphicaleffects.mk
package/qt5/qt5multimedia/qt5multimedia.mk
package/qt5/qt5svg/qt5svg.mk
package/qt5/qt5webkit/qt5webkit.mk

index 036cf2128033b0ef2c638aeab51c8fbe553bf2f8..2c3f66a2eecf74648d90977ab53ce4ea3a8e9f61 100644 (file)
@@ -12,9 +12,7 @@ QT5GRAPHICALEFFECTS_INSTALL_STAGING = YES
 
 ifeq ($(BR2_PACKAGE_QT5BASE_LICENSE_APPROVED),y)
 QT5GRAPHICALEFFECTS_LICENSE = LGPLv2.1 or GPLv3.0
-# Here we would like to get license files from qt5base, but qt5base
-# may not be extracted at the time we get the legal-info for
-# qt5script.
+QT5GRAPHICALEFFECTS_LICENSE_FILES = LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt
 else
 QT5GRAPHICALEFFECTS_LICENSE = Commercial license
 QT5GRAPHICALEFFECTS_REDISTRIBUTE = NO
index e7ac56251454a0bc7c120421544dbb940f9820fb..5eef543e0d39577dd839be57e9ca323fc1d9ab2e 100644 (file)
@@ -12,9 +12,7 @@ QT5MULTIMEDIA_INSTALL_STAGING = YES
 
 ifeq ($(BR2_PACKAGE_QT5BASE_LICENSE_APPROVED),y)
 QT5MULTIMEDIA_LICENSE = LGPLv2.1 or GPLv3.0
-# Here we would like to get license files from qt5base, but qt5base
-# may not be extracted at the time we get the legal-info for
-# qt5script.
+QT5MULTIMEDIA_LICENSE_FILES = LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt
 else
 QT5MULTIMEDIA_LICENSE = Commercial license
 QT5MULTIMEDIA_REDISTRIBUTE = NO
index da981f4126563151dff9ee0598c8c86b62d2ce3d..a768acbedee394a5809a6f99f2e0ffc5c4d1a1f2 100644 (file)
@@ -12,8 +12,7 @@ QT5SVG_INSTALL_STAGING = YES
 
 ifeq ($(BR2_PACKAGE_QT5BASE_LICENSE_APPROVED),y)
 QT5SVG_LICENSE = LGPLv2.1 or GPLv3.0
-# Here we would like to get license files from qt5base, but qt5base
-# may not be extracted at the time we get the legal-info for qt5svg.
+QT5SVG_LICENSE_FILES = LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt
 else
 QT5SVG_LICENSE = Commercial license
 QT5SVG_REDISTRIBUTE = NO
index 33b775d06eb2b7ab440474ccde848a50151ce590..08c30be45d22198d43f77059fad717b885a3c078 100644 (file)
@@ -11,14 +11,12 @@ QT5WEBKIT_DEPENDENCIES = qt5base sqlite host-ruby host-gperf host-bison host-fle
 QT5WEBKIT_INSTALL_STAGING = YES
 
 ifeq ($(BR2_PACKAGE_QT5BASE_LICENSE_APPROVED),y)
-QT5WEBKIT_LICENSE = LGPLv2.1 or GPLv3.0
-# Here we would like to get license files from qt5base, but qt5base
-# may not be extracted at the time we get the legal-info for
-# qt5script.
+QT5WEBKIT_LICENSE = LGPLv2+, MIT
 else
-QT5WEBKIT_LICENSE = Commercial license
+QT5WEBKIT_LICENSE = LGPLv2+, MIT, Commercial license
 QT5WEBKIT_REDISTRIBUTE = NO
 endif
+QT5WEBKIT_LICENSE_FILES = Source/WebCore/LICENSE-LGPL-2 Source/WebCore/LICENSE-LGPL-2.1 Source/WebKit/LICENSE
 
 ifeq ($(BR2_PACKAGE_QT5BASE_XCB),y)
 QT5WEBKIT_DEPENDENCIES += xlib_libXext xlib_libXrender