package/omxplayer: add missing dependency to alsa-lib
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 4 Dec 2017 21:31:03 +0000 (22:31 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 6 Dec 2017 20:54:36 +0000 (21:54 +0100)
Since the bump in 58a00a13 (omxplayer: bump to version 2ee17b2),
omxplayer gained a dependency to alsa-lib.

Fixes:
    http://autobuild.buildroot.org/results/652/65212c59a37398681b341263bd76ba8a65ff7828/

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Julius Kriukas <julius@kriukas.lt>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/omxplayer/Config.in
package/omxplayer/omxplayer.mk

index b417aa3b0be76a03457b261ef856d6e79915038c..bdb3f4054d6dc6a983e64c7f2055663258adacdf 100644 (file)
@@ -4,9 +4,10 @@ config BR2_PACKAGE_OMXPLAYER
        depends on BR2_USE_MMU # dbus
        depends on BR2_PACKAGE_FFMPEG_ARCH_SUPPORTS # ffmpeg
        depends on BR2_INSTALL_LIBSTDCPP # boost
-       depends on BR2_TOOLCHAIN_HAS_THREADS # boost, libusb
+       depends on BR2_TOOLCHAIN_HAS_THREADS # alsa-lib, boost, libusb
        depends on BR2_USE_WCHAR # boost
        depends on BR2_PACKAGE_RPI_USERLAND
+       select BR2_PACKAGE_ALSA_LIB
        select BR2_PACKAGE_BOOST
        select BR2_PACKAGE_DBUS
        select BR2_PACKAGE_FFMPEG
index 6e92250438c634a41b6182e27dce538adb50f801..6999269161d3ef34a773c21b0196cc8324981c7f 100644 (file)
@@ -10,7 +10,7 @@ OMXPLAYER_LICENSE = GPL-2.0+
 OMXPLAYER_LICENSE_FILES = COPYING
 
 OMXPLAYER_DEPENDENCIES = \
-       host-pkgconf boost dbus ffmpeg freetype libidn libusb pcre \
+       host-pkgconf alsa-lib boost dbus ffmpeg freetype libidn libusb pcre \
        rpi-userland zlib
 
 OMXPLAYER_EXTRA_CFLAGS = \