udev: update udev to new virtual package infra.
authoreric.le.bihan.dev@free.fr <eric.le.bihan.dev@free.fr>
Mon, 24 Feb 2014 09:25:41 +0000 (10:25 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 25 Feb 2014 20:27:11 +0000 (21:27 +0100)
The udev virtual package and its current providers (eudev and systemd)
have been updated to use the latest version of virtual package
infrastructure.

A provider should now select BR2_PACKAGE_HAS_UDEV and well as set a
value for BR2_PACKAGE_PROVIDES_UDEV.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/eudev/Config.in
package/systemd/Config.in
package/udev/Config.in
package/udev/udev.mk

index bfad99a271493cfbabcb1d737608d15b150807e9..40ff7218264d570132146bcc876bcfa89cd0efe1 100644 (file)
@@ -21,6 +21,9 @@ config BR2_PACKAGE_EUDEV
 
 if BR2_PACKAGE_EUDEV
 
+config BR2_PACKAGE_PROVIDES_UDEV
+       default "eudev"
+
 config BR2_PACKAGE_EUDEV_RULES_GEN
        bool "enable rules generator"
        help
index e3ea433728113a3c9ec3e1386a36a51f8d39e3be..eacc23cc6e115026124f7011d049d5e043506a5e 100644 (file)
@@ -40,6 +40,9 @@ config BR2_PACKAGE_SYSTEMD
 
 if BR2_PACKAGE_SYSTEMD
 
+config BR2_PACKAGE_PROVIDES_UDEV
+       default "systemd"
+
 config BR2_PACKAGE_SYSTEMD_ALL_EXTRAS
        bool "enable all extras"
        select BR2_PACKAGE_XZ
index 5cd40516210af435890fcb0350795579492f8809..941a5152ffd494c24bcea23c386a9b83cfc4803b 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_HAS_UDEV
        bool
-       help
-         udev is now a virtual package.
-         Packages requiring udevd at run time or libudev/gudev at build time
-         should select it.
+
+config BR2_PACKAGE_PROVIDES_UDEV
+       depends on BR2_PACKAGE_HAS_UDEV
+       string
index a5d0f800cafb925079efde797f40e414ab0d99ed..f5eeeb494bc1939e52e7063ea2340d5616cc6b69 100644 (file)
@@ -5,20 +5,12 @@
 ################################################################################
 
 UDEV_SOURCE =
+UDEV_DEPENDENCIES = $(call qstrip,$(BR2_PACKAGE_PROVIDES_UDEV))
 
-ifeq ($(BR2_PACKAGE_EUDEV),y)
-UDEV_DEPENDENCIES += eudev
-endif
-
-ifeq ($(BR2_PACKAGE_SYSTEMD),y)
-UDEV_DEPENDENCIES += systemd
-endif
-
+ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
 ifeq ($(UDEV_DEPENDENCIES),)
-define UDEV_CONFIGURE_CMDS
-       echo "No Udev implementation selected. Configuration error."
-       exit 1
-endef
+$(error No Udev implementation selected. Configuration error)
+endif
 endif
 
 $(eval $(generic-package))