lighttpd: bump to version 1.4.31
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 8 Jun 2012 05:30:45 +0000 (05:30 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 10 Jun 2012 19:54:39 +0000 (21:54 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/lighttpd/lighttpd-1.4.30-Fix-default-config-file.patch [deleted file]
package/lighttpd/lighttpd-Fix-default-config-file.patch [new file with mode: 0644]
package/lighttpd/lighttpd.mk

diff --git a/package/lighttpd/lighttpd-1.4.30-Fix-default-config-file.patch b/package/lighttpd/lighttpd-1.4.30-Fix-default-config-file.patch
deleted file mode 100644 (file)
index 59ce907..0000000
+++ /dev/null
@@ -1,92 +0,0 @@
-Modify the default lighttpd configuration file to have one a starting conf
-
-  * Changed the log path to /var/log and logs filenames
-  * Disable IPv6
-  * Do not setuid to a user that doesn't exist on the system
-  * Disable pdf ranges fix for Adobe Reader since it uses regex and we
-    don't always have pcre support
-  * Change the network backend to writev since linux-sendfile fails on buildroot
-
-Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
----
- doc/config/conf.d/access_log.conf |    2 +-
- doc/config/lighttpd.conf          |   18 +++++++++---------
- 2 files changed, 10 insertions(+), 10 deletions(-)
-
-Index: lighttpd-1.4.30/doc/config/lighttpd.conf
-===================================================================
---- lighttpd-1.4.30.orig/doc/config/lighttpd.conf
-+++ lighttpd-1.4.30/doc/config/lighttpd.conf
-@@ -13,7 +13,7 @@
- ## if you add a variable here. Add the corresponding variable in the
- ## chroot example aswell.
- ##
--var.log_root    = "/var/log/lighttpd"
-+var.log_root    = "/var/log"
- var.server_root = "/srv/www"
- var.state_dir   = "/var/run"
- var.home_dir    = "/var/lib/lighttpd"
-@@ -90,7 +90,7 @@
- ##
- ## Use IPv6?
- ##
--server.use-ipv6 = "enable"
-+# server.use-ipv6 = "enable"
- ##
- ## bind to a specific IP
-@@ -101,8 +101,8 @@
- ## Run as a different username/groupname.
- ## This requires root permissions during startup. 
- ##
--server.username  = "lighttpd"
--server.groupname = "lighttpd"
-+# server.username  = "lighttpd"
-+# server.groupname = "lighttpd"
- ## 
- ## enable core files.
-@@ -138,7 +138,7 @@
- ##
- ## Path to the error log file
- ##
--server.errorlog             = log_root + "/error.log"
-+server.errorlog             = log_root + "/lighttpd-error.log"
- ##
- ## If you want to log to syslog you have to unset the 
-@@ -188,7 +188,7 @@
- ## linux-sendfile - is recommended for small files.
- ## writev         - is recommended for sending many large files
- ##
--server.network-backend = "linux-sendfile"
-+server.network-backend = "writev"
- ##
- ## As lighttpd is a single-threaded server, its main resource limit is
-@@ -311,9 +311,9 @@
- ## disable range requests for pdf files
- ## workaround for a bug in the Acrobat Reader plugin.
- ##
--$HTTP["url"] =~ "\.pdf$" {
--  server.range-requests = "disable"
--}
-+# $HTTP["url"] =~ "\.pdf$" {
-+#  server.range-requests = "disable"
-+# }
- ##
- ## url handling modules (rewrite, redirect)
-Index: lighttpd-1.4.30/doc/config/conf.d/access_log.conf
-===================================================================
---- lighttpd-1.4.30.orig/doc/config/conf.d/access_log.conf
-+++ lighttpd-1.4.30/doc/config/conf.d/access_log.conf
-@@ -9,7 +9,7 @@
- ##
- ## Default access log.
- ##
--accesslog.filename          = log_root + "/access.log"
-+accesslog.filename          = log_root + "/lighttpd-access.log"
- ##
- ## The default format produces CLF compatible output.
diff --git a/package/lighttpd/lighttpd-Fix-default-config-file.patch b/package/lighttpd/lighttpd-Fix-default-config-file.patch
new file mode 100644 (file)
index 0000000..59ce907
--- /dev/null
@@ -0,0 +1,92 @@
+Modify the default lighttpd configuration file to have one a starting conf
+
+  * Changed the log path to /var/log and logs filenames
+  * Disable IPv6
+  * Do not setuid to a user that doesn't exist on the system
+  * Disable pdf ranges fix for Adobe Reader since it uses regex and we
+    don't always have pcre support
+  * Change the network backend to writev since linux-sendfile fails on buildroot
+
+Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
+---
+ doc/config/conf.d/access_log.conf |    2 +-
+ doc/config/lighttpd.conf          |   18 +++++++++---------
+ 2 files changed, 10 insertions(+), 10 deletions(-)
+
+Index: lighttpd-1.4.30/doc/config/lighttpd.conf
+===================================================================
+--- lighttpd-1.4.30.orig/doc/config/lighttpd.conf
++++ lighttpd-1.4.30/doc/config/lighttpd.conf
+@@ -13,7 +13,7 @@
+ ## if you add a variable here. Add the corresponding variable in the
+ ## chroot example aswell.
+ ##
+-var.log_root    = "/var/log/lighttpd"
++var.log_root    = "/var/log"
+ var.server_root = "/srv/www"
+ var.state_dir   = "/var/run"
+ var.home_dir    = "/var/lib/lighttpd"
+@@ -90,7 +90,7 @@
+ ##
+ ## Use IPv6?
+ ##
+-server.use-ipv6 = "enable"
++# server.use-ipv6 = "enable"
+ ##
+ ## bind to a specific IP
+@@ -101,8 +101,8 @@
+ ## Run as a different username/groupname.
+ ## This requires root permissions during startup. 
+ ##
+-server.username  = "lighttpd"
+-server.groupname = "lighttpd"
++# server.username  = "lighttpd"
++# server.groupname = "lighttpd"
+ ## 
+ ## enable core files.
+@@ -138,7 +138,7 @@
+ ##
+ ## Path to the error log file
+ ##
+-server.errorlog             = log_root + "/error.log"
++server.errorlog             = log_root + "/lighttpd-error.log"
+ ##
+ ## If you want to log to syslog you have to unset the 
+@@ -188,7 +188,7 @@
+ ## linux-sendfile - is recommended for small files.
+ ## writev         - is recommended for sending many large files
+ ##
+-server.network-backend = "linux-sendfile"
++server.network-backend = "writev"
+ ##
+ ## As lighttpd is a single-threaded server, its main resource limit is
+@@ -311,9 +311,9 @@
+ ## disable range requests for pdf files
+ ## workaround for a bug in the Acrobat Reader plugin.
+ ##
+-$HTTP["url"] =~ "\.pdf$" {
+-  server.range-requests = "disable"
+-}
++# $HTTP["url"] =~ "\.pdf$" {
++#  server.range-requests = "disable"
++# }
+ ##
+ ## url handling modules (rewrite, redirect)
+Index: lighttpd-1.4.30/doc/config/conf.d/access_log.conf
+===================================================================
+--- lighttpd-1.4.30.orig/doc/config/conf.d/access_log.conf
++++ lighttpd-1.4.30/doc/config/conf.d/access_log.conf
+@@ -9,7 +9,7 @@
+ ##
+ ## Default access log.
+ ##
+-accesslog.filename          = log_root + "/access.log"
++accesslog.filename          = log_root + "/lighttpd-access.log"
+ ##
+ ## The default format produces CLF compatible output.
index 8d1f212e17cefa562963b1c0889f428cdf432f31..c7fae32413403c544d626415302767aa3c73a4e8 100644 (file)
@@ -4,7 +4,7 @@
 #
 #############################################################
 
-LIGHTTPD_VERSION = 1.4.30
+LIGHTTPD_VERSION = 1.4.31
 LIGHTTPD_SITE = http://download.lighttpd.net/lighttpd/releases-1.4.x
 LIGHTTPD_DEPENDENCIES = host-pkg-config
 LIGHTTPD_CONF_OPT = \