package: create virtual package for libGLES, libOpenVG and libEGL
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 6 Mar 2013 10:22:47 +0000 (10:22 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 6 Mar 2013 21:07:56 +0000 (22:07 +0100)
Those acceleration libraries typically have multiple implementations:
some are free (Mesa), some are proprietary (generally SoC specific).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/opengl/Config.in [new file with mode: 0644]
package/opengl/libegl/libegl.mk [new file with mode: 0644]
package/opengl/libgles/libgles.mk [new file with mode: 0644]
package/opengl/libopenvg/libopenvg.mk [new file with mode: 0644]
package/opengl/opengl.mk [new file with mode: 0644]

index 370676383b2e9bc17d36692da1c003723b438be5..22e64f869284aca41ea8fbb02f5b6b0a05901f62 100644 (file)
@@ -435,6 +435,7 @@ source "package/librsvg/Config.in"
 source "package/libsvgtiny/Config.in"
 source "package/libungif/Config.in"
 source "package/opencv/Config.in"
+source "package/opengl/Config.in"
 source "package/pango/Config.in"
 source "package/pixman/Config.in"
 source "package/tiff/Config.in"
diff --git a/package/opengl/Config.in b/package/opengl/Config.in
new file mode 100644 (file)
index 0000000..81616f9
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_HAS_OPENGL_EGL
+       bool
+
+config BR2_PACKAGE_HAS_OPENGL_ES
+       bool
+
+config BR2_PACKAGE_HAS_OPENVG
+       bool
diff --git a/package/opengl/libegl/libegl.mk b/package/opengl/libegl/libegl.mk
new file mode 100644 (file)
index 0000000..56cc8ac
--- /dev/null
@@ -0,0 +1,16 @@
+#############################################################
+#
+# Virtual package for libEGL
+#
+#############################################################
+
+LIBEGL_SOURCE =
+
+ifeq ($(LIBEGL_DEPENDENCIES),y)
+define LIBEGL_CONFIGURE_CMDS
+       echo "No libEGL implementation selected. Configuration error."
+       exit 1
+endef
+endif
+
+$(eval $(generic-package))
diff --git a/package/opengl/libgles/libgles.mk b/package/opengl/libgles/libgles.mk
new file mode 100644 (file)
index 0000000..753f53e
--- /dev/null
@@ -0,0 +1,16 @@
+#############################################################
+#
+# Virtual package for libGLES
+#
+#############################################################
+
+LIBGLES_SOURCE =
+
+ifeq ($(LIBGLES_DEPENDENCIES),y)
+define LIBGLES_CONFIGURE_CMDS
+       echo "No libGLES implementation selected. Configuration error."
+       exit 1
+endef
+endif
+
+$(eval $(generic-package))
diff --git a/package/opengl/libopenvg/libopenvg.mk b/package/opengl/libopenvg/libopenvg.mk
new file mode 100644 (file)
index 0000000..2fcc99f
--- /dev/null
@@ -0,0 +1,16 @@
+#############################################################
+#
+# Virtual package for libOpenVG
+#
+#############################################################
+
+LIBOPENVG_SOURCE =
+
+ifeq ($(LIBOPENVG_DEPENDENCIES),y)
+define LIBOPENVG_CONFIGURE_CMDS
+       echo "No libOpenVG implementation selected. Configuration error."
+       exit 1
+endef
+endif
+
+$(eval $(generic-package))
diff --git a/package/opengl/opengl.mk b/package/opengl/opengl.mk
new file mode 100644 (file)
index 0000000..68df3b1
--- /dev/null
@@ -0,0 +1 @@
+include package/opengl/*/*.mk