package/uvw: new package
authorAsaf Kahlon <asafka7@gmail.com>
Sat, 26 Oct 2019 14:02:04 +0000 (17:02 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 26 Oct 2019 14:26:56 +0000 (16:26 +0200)
A header-only libuv wrapper in C++.

Signed-off-by: Asaf Kahlon <asafka7@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/libuv/libuv.mk
package/uvw/Config.in [new file with mode: 0644]
package/uvw/uvw.hash [new file with mode: 0644]
package/uvw/uvw.mk [new file with mode: 0644]

index ec4f50a79ef5d68d4c826d1978939e887cf9510f..b9e6881419b5b777f4844ab6d99039557b209d88 100644 (file)
@@ -239,6 +239,7 @@ F:  package/python*
 F:     package/snmpclitools/
 F:     package/spdlog/
 F:     package/uftp/
+F:     package/uvw/
 F:     package/zeromq/
 
 N:     Ash Charles <ashcharles@gmail.com>
index d78b4c444b1b9bcd62ccb845390ae2f483fdfc61..901c25fe028f5a1760efc5105531e9e80864ba8b 100644 (file)
@@ -1805,6 +1805,7 @@ endif
        source "package/tinycbor/Config.in"
        source "package/tz/Config.in"
        source "package/tzdata/Config.in"
+       source "package/uvw/Config.in"
        source "package/xapian/Config.in"
 endmenu
 
index d5f1d7dbabae4578bc5439b94d3a7376f4f59d45..618b25d5f62b42556684d2ebd42135d5d9a4c777 100644 (file)
@@ -4,6 +4,8 @@
 #
 ################################################################################
 
+# When bumping libuv, check if a new version of uvw is available
+# and bump it too.
 LIBUV_VERSION = 1.33.1
 LIBUV_SITE = $(call github,libuv,libuv,v$(LIBUV_VERSION))
 LIBUV_DEPENDENCIES = host-pkgconf
diff --git a/package/uvw/Config.in b/package/uvw/Config.in
new file mode 100644 (file)
index 0000000..bfaed25
--- /dev/null
@@ -0,0 +1,19 @@
+config BR2_PACKAGE_UVW
+       bool "uvw"
+       depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL # libuv
+       depends on BR2_USE_MMU # libuv
+       depends on !BR2_STATIC_LIBS # libuv
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4 # libuv
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_7 # C++17
+       select BR2_PACKAGE_LIBUV
+       help
+         Header-only, event based, tiny and easy to use
+         libuv wrapper in modern C++.
+
+         https://github.com/skypjack/uvw
+
+comment "uvw needs a toolchain w/ NPTL, dynamic library, gcc >= 7"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL || BR2_STATIC_LIBS || \
+               !BR2_TOOLCHAIN_GCC_AT_LEAST_7
+       depends on BR2_USE_MMU
+       depends on BR2_TOOLCHAIN_HAS_SYNC_4
diff --git a/package/uvw/uvw.hash b/package/uvw/uvw.hash
new file mode 100644 (file)
index 0000000..e6129e5
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256  266a354f0c64a8e85f29b10f20f4d08a35bc1e8caa7cc94a8afecf9ca43f4442  uvw-2.2.0_libuv-v1.33.tar.gz
+sha256  ea786619b4d1b2ba0a188e923111122dfefea1d01c86e37f9e8c80bdbc3ea400  LICENSE
diff --git a/package/uvw/uvw.mk b/package/uvw/uvw.mk
new file mode 100644 (file)
index 0000000..64122ae
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# uvw
+#
+################################################################################
+
+UVW_VERSION = 2.2.0_libuv-v1.33
+UVW_SITE = $(call github,skypjack,uvw,v$(UVW_VERSION))
+UVW_INSTALL_STAGING = YES
+UVW_INSTALL_TARGET = NO
+UVW_SUPPORTS_IN_SOURCE_BUILD = NO
+UVW_DEPENDENCIES = libuv
+UVW_LICENSE = MIT
+UVW_LICENSE_FILES = LICENSE
+
+$(eval $(cmake-package))