package/mpd: opus plugin needs libogg as well
authorJörg Krause <jkrause@posteo.de>
Tue, 26 Aug 2014 09:26:28 +0000 (11:26 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 27 Aug 2014 14:49:51 +0000 (16:49 +0200)
Fixes http://autobuild.buildroot.net/results/492/4924194292a428a295ded2f7aa0b9a3f81ed1b4a/

The opus decoder plugin depends on libopus and libogg.

[Peter: reworded commit message]
Signed-off-by: Jörg Krause <jkrause@posteo.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mpd/Config.in
package/mpd/mpd.mk

index b8a56b75ddad2095d73ce3ae698781db51ff2c7f..108b2b107a862a553553c320ba1644cb869bba42 100644 (file)
@@ -145,6 +145,7 @@ config BR2_PACKAGE_MPD_MUSEPACK
 config BR2_PACKAGE_MPD_OPUS
        bool "opus"
        select BR2_PACKAGE_OPUS
+       select BR2_PACKAGE_LIBOGG
        help
          Enable opus input support.
          Select this if you want to play back OPUS encoded files.
index df940359fb21c51304cef22eff48bc5f065d3883..f84c6d0031a73fcf0fb7e6c4cbdc8884e41ec480 100644 (file)
@@ -97,7 +97,7 @@ MPD_CONF_OPT += --disable-sndfile
 endif
 
 ifeq ($(BR2_PACKAGE_MPD_OPUS),y)
-MPD_DEPENDENCIES += opus
+MPD_DEPENDENCIES += opus libogg
 MPD_CONF_OPT += --enable-opus
 else
 MPD_CONF_OPT += --disable-opus