package/uboot-tools: fix MKIMAGE_ARCH handling
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 8 Sep 2021 16:45:36 +0000 (18:45 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 11 Sep 2021 20:29:13 +0000 (22:29 +0200)
Fix MKIMAGE_ARCH handling to avoid the following build failure:

/home/buildroot/autobuild/instance-0/output-1/build/host-uboot-tools-2021.07/tools/mkimage -C none -A openrisc -T script -d /home/buildroot/autobuild/instance-0/output-1/boot_script.txt /home/buildroot/autobuild/instance-0/output-1/build/host-uboot-tools-2021.07/tools/boot.scr

Invalid architecture, supported are:
alpha            Alpha
arc              ARC
arm              ARM
arm64            AArch64
avr32            AVR32
blackfin         Blackfin
ia64             IA64
invalid          Invalid ARCH
m68k             M68K
microblaze       MicroBlaze
mips             MIPS
mips64           MIPS 64 Bit
nds32            NDS32
nios2            NIOS II
or1k             OpenRISC 1000
powerpc          PowerPC
riscv            RISC-V
s390             IBM S390
sandbox          Sandbox
sh               SuperH
sparc            SPARC
sparc64          SPARC 64 Bit
x86              Intel x86
x86_64           AMD x86_64
xtensa           Xtensa

Strangely enough, we only have autobuilder failures since July 2021 even
as or1k has been used since the addition of openriscv support in 2012:
https://github.com/u-boot/u-boot/commit/3ddcaccda3824e1c7f7266d543e4c0eb3ea9851c

For x86)64, we incorrectly mangle it to x86.

Finally, the comment about mips64 is wrong: mips64 *is* a valid
archtecture, and we anyway had no code to tweak that case.

Fixes:
 - http://autobuild.buildroot.org/results/c3f0f2a3fb87d74bfdaccf9b94c66f0b5bae7520

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr: extend commit log for mips64 and x86_64]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/uboot-tools/uboot-tools.mk

index a87956d0283a365540773d6310485250fe9d9f2e..81f60963ecf97d7ddd64e5a838c3338ebb686c93 100644 (file)
@@ -206,15 +206,15 @@ $(eval $(host-generic-package))
 
 MKIMAGE = $(HOST_DIR)/bin/mkimage
 
-# mkimage supports arm blackfin m68k microblaze mips mips64 nios2 powerpc ppc sh sparc sparc64 x86
+# mkimage supports alpha arc arm arm64 blackfin ia64 invalid m68k microblaze mips mips64 nds32 nios2 or1k powerpc riscv s390 sandbox sh sparc sparc64 x86 x86_64 xtensa
 # KERNEL_ARCH can be arm64 arc arm blackfin m68k microblaze mips nios2 powerpc sh sparc i386 x86_64 xtensa
-# For arm64, arc, xtensa we'll just keep KERNEL_ARCH
-# For mips64, we'll just keep mips
-# For i386 and x86_64, we need to convert
-ifeq ($(KERNEL_ARCH),x86_64)
-MKIMAGE_ARCH = x86
-else ifeq ($(KERNEL_ARCH),i386)
+# For i386, we need to convert
+# For openrisc, we need to convert
+# For others, we'll just keep KERNEL_ARCH
+ifeq ($(KERNEL_ARCH),i386)
 MKIMAGE_ARCH = x86
+else ifeq ($(KERNEL_ARCH),openrisc)
+MKIMAGE_ARCH = or1k
 else
 MKIMAGE_ARCH = $(KERNEL_ARCH)
 endif