mesa3d: specify llvm-prefix
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 30 Mar 2015 23:16:00 +0000 (20:16 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 31 Mar 2015 11:54:47 +0000 (13:54 +0200)
When it's not defined an automatic search is triggered, which can find
/usr/bin/llvm-config on distributions that include all development files
(like gentoo) and have desktop packages installed.
So point it towards the staging dir which is where it should live
eventually if/when we've got it to avoid header/include path polution
that otherwise leads to build failures.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mesa3d/mesa3d.mk

index fc82227b2e5a23f521f8bad9f87bbd088bd5da27..747311021f0ef5e14749ed3b5948dda84505aa1b 100644 (file)
@@ -128,4 +128,7 @@ else
 MESA3D_CONF_OPTS += --disable-gles1 --disable-gles2
 endif
 
+# Avoid automatic search of llvm-config
+MESA3D_CONF_OPTS += --with-llvm-prefix=$(STAGING_DIR)/usr/bin
+
 $(eval $(autotools-package))