pkg-autotools: fix whitespace regex in libtool patch hook
authorDanomi Manchego <danomimanchego123@gmail.com>
Tue, 7 Jul 2015 04:34:00 +0000 (00:34 -0400)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 9 Jul 2015 05:58:02 +0000 (07:58 +0200)
The first sed line for ltmain_version attempts to match whitespace before
VERSION with [ space_character tab_character ]. The second sed line used to
make ltmain_patchlevel has only space characters in the whitespace expression,
possibly due to a smart editor automatically converting tabs to spaces. Make
these lines consistent with each other and more resilient against accidental
loss of tab characters by replacing the tabs with '\t'.

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-autotools.mk

index 54f5dcd45c4f90a435f368cba09aeaa8dc771328..c748c78579852dc94b36d9371f7b59a1dafc5503 100644 (file)
@@ -60,9 +60,9 @@ endef
 define LIBTOOL_PATCH_HOOK
        @$(call MESSAGE,"Patching libtool")
        $(Q)for i in `find $($(PKG)_SRCDIR) -name ltmain.sh`; do \
-               ltmain_version=`sed -n '/^[     ]*VERSION=/{s/^[        ]*VERSION=//;p;q;}' $$i | \
+               ltmain_version=`sed -n '/^[ \t]*VERSION=/{s/^[ \t]*VERSION=//;p;q;}' $$i | \
                sed -e 's/\([0-9]*\.[0-9]*\).*/\1/' -e 's/\"//'`; \
-               ltmain_patchlevel=`sed -n '/^[     ]*VERSION=/{s/^[        ]*VERSION=//;p;q;}' $$i | \
+               ltmain_patchlevel=`sed -n '/^[ \t]*VERSION=/{s/^[ \t]*VERSION=//;p;q;}' $$i | \
                sed -e 's/\([0-9]*\.[0-9]*\.*\)\([0-9]*\).*/\2/' -e 's/\"//'`; \
                if test $${ltmain_version} = '1.5'; then \
                        $(APPLY_PATCHES) $${i%/*} support/libtool buildroot-libtool-v1.5.patch; \