package/webkitgtk: disable JSC JIT for MIPSr6
authorAdrian Perez de Castro <aperez@igalia.com>
Tue, 11 Feb 2020 20:44:44 +0000 (22:44 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 11 Feb 2020 22:33:45 +0000 (23:33 +0100)
Forcibly disable the JavaScriptCore JIT compilation support
for MIPSr6 processors, which are unsupported.

Fixes: http://autobuild.buildroot.net/results/3d21d3c3460cd85a4c828dd197929cdf17aaf4e0
Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/webkitgtk/webkitgtk.mk

index e5d591fcd2216eec45a154c756f3c74a5b4c227a..cbd900307146757114d443c687efc71d24d2ad6e 100644 (file)
@@ -104,4 +104,13 @@ else
 WEBKITGTK_CONF_OPTS += -DUSE_GSTREAMER_GL=OFF
 endif
 
+# JIT is not supported for MIPS r6, but the WebKit build system does not
+# have a check for these processors. Disable JIT forcibly here and use
+# the CLoop interpreter instead.
+#
+# Upstream bug: https://bugs.webkit.org/show_bug.cgi?id=191258
+ifeq ($(BR2_MIPS_CPU_MIPS32R6)$(BR2_MIPS_CPU_MIPS64R6),y)
+WEBKITGTK_CONF_OPTS += -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON
+endif
+
 $(eval $(cmake-package))