package/modem-manager: fix build without xsltproc
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 5 Nov 2020 07:47:39 +0000 (08:47 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 5 Nov 2020 08:40:11 +0000 (09:40 +0100)
Commit 8efb52c1a17210dc79cfb61f56a71ffb760ccbe9 added a libxslt
dependency presumably to manage
https://github.com/freedesktop/ModemManager/commit/bbd39a457ce2949dd167f9c2e01eecf6a9e14716

However, this is wrong and build will fail on:

checking for xsltproc... no
configure: error: Please install xsltproc before configuring.

xsltproc is used to generate ModemManager-names.h since, at least,
version 0.7.990 and
https://github.com/freedesktop/ModemManager/commit/365b906a3e1bda05af10f92451a6b6ae60f8b879
However, this file is already available in the official tarball so drop
this unneeded dependency and set ac_cv_prog_XSLTPROC_CHECK to yes

Fixes:
 - http://autobuild.buildroot.org/results/edc755b874ea43d1c009ad76c28f05e18519138e

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/modem-manager/Config.in
package/modem-manager/modem-manager.mk

index 062826fd0a7de19f6470f17f20bd33d54e1d4681..c4c723776d0636e9f7741cc98d40c3baf2d24803 100644 (file)
@@ -6,7 +6,6 @@ config BR2_PACKAGE_MODEM_MANAGER
        select BR2_PACKAGE_DBUS # runtime dependency
        select BR2_PACKAGE_LIBGLIB2
        select BR2_PACKAGE_LIBGUDEV if BR2_PACKAGE_HAS_UDEV
-       select BR2_PACKAGE_LIBXSLT
        help
          ModemManager is a DBus-activated daemon which controls mobile
          broadband (2G/3G/4G) devices and connections.
index 53cd0aff9a6d3fb6e293173119796fe2dfa4ad90..372e7da1e4c3bbdd7ba1675b3deeed93e8086654 100644 (file)
@@ -9,9 +9,10 @@ MODEM_MANAGER_SOURCE = ModemManager-$(MODEM_MANAGER_VERSION).tar.xz
 MODEM_MANAGER_SITE = http://www.freedesktop.org/software/ModemManager
 MODEM_MANAGER_LICENSE = GPL-2.0+ (programs, plugins), LGPL-2.0+ (libmm-glib)
 MODEM_MANAGER_LICENSE_FILES = COPYING COPYING.LIB
-MODEM_MANAGER_DEPENDENCIES = host-pkgconf libglib2 libxslt $(TARGET_NLS_DEPENDENCIES)
+MODEM_MANAGER_DEPENDENCIES = host-pkgconf libglib2 $(TARGET_NLS_DEPENDENCIES)
 MODEM_MANAGER_INSTALL_STAGING = YES
 MODEM_MANAGER_CONF_OPTS = --disable-more-warnings
+MODEM_MANAGER_CONF_ENV = ac_cv_prog_XSLTPROC_CHECK=yes
 
 ifeq ($(BR2_PACKAGE_MODEM_MANAGER_LIBQMI),y)
 MODEM_MANAGER_DEPENDENCIES += libqmi