c-icap: disable Perl support
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Jul 2015 10:43:29 +0000 (12:43 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Jul 2015 10:43:29 +0000 (12:43 +0200)
The Perl support in c-icap does not build properly, because it queries
the system-installed Perl for cflags/ldflags, which returns things
like -I/usr/local/include causing build failures since those are
invalid paths when cross-compiling.

Since there is no easy way to fix that without changing c-icap
configure.in, let's disable the Perl support for now, until someone is
interested enough to fix this up.

Fixes:

  http://autobuild.buildroot.org/results/f60/f6011ab8211589fe8e1e8932db9f8be81768d3e6/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/c-icap/c-icap.mk

index 51c0f5fc2925d0ea816e8c6791bb78a2fa63e342..0f42b6cfb1bdd90cf98878d3a53cae49f59059f8 100644 (file)
@@ -14,6 +14,7 @@ C_ICAP_CONFIG_SCRIPTS = c-icap-config c-icap-libicapapi-config
 C_ICAP_CONF_OPTS = \
        --with-process-mutexes=posix \
        --without-ldap \
+       --without-perl \
        --enable-large-files \
        --enable-ipv6
 
@@ -31,13 +32,6 @@ else
 C_ICAP_CONF_OPTS += --without-bzip2
 endif
 
-ifeq ($(BR2_PACKAGE_PERL),y)
-C_ICAP_CONF_OPTS += --with-perl
-C_ICAP_DEPENDENCIES += perl
-else
-C_ICAP_CONF_OPTS += --without-perl
-endif
-
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 C_ICAP_CONF_OPTS += --with-zlib
 C_ICAP_DEPENDENCIES += zlib