package/powertop: needs gettextize, 2nd try
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 27 Mar 2015 14:20:30 +0000 (15:20 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 27 Mar 2015 15:36:42 +0000 (16:36 +0100)
If host-gettext was compiled before powertop it is picked up by autoreconf which
leads to a broken compile. To fix this unconditionally include host-gettext as
dependency and move

POWERTOP_GETTEXTIZE = YES

outside the if-clause for BR2_NEEDS_GETTEXT

Fixes
http://autobuild.buildroot.net/results/24e/24e312271cf07a8dd966b43f153a06ddc858a786/
http://autobuild.buildroot.net/results/511/511a1c76bfd0ebf637e5abcd6fecc4d6a683ed3e/
http://autobuild.buildroot.net/results/652/65246f6f71e67c2637efbe8bb6e501750629d5fb/

and many others

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/powertop/powertop.mk

index 4446bc988a198f031e6fbc8b36c65d766cb0bb89..331edc9f5d935075523c4c0ab31b276c32820e7d 100644 (file)
@@ -6,14 +6,14 @@
 
 POWERTOP_VERSION = 2.7
 POWERTOP_SITE = https://01.org/sites/default/files/downloads/powertop/
-POWERTOP_DEPENDENCIES = pciutils ncurses libnl host-pkgconf
+POWERTOP_DEPENDENCIES = pciutils ncurses libnl host-gettext host-pkgconf
 POWERTOP_LICENSE = GPLv2
 POWERTOP_LICENSE_FILES = COPYING
 # We're patching Makefile.am
 POWERTOP_AUTORECONF = YES
+POWERTOP_GETTEXTIZE = YES
 
 ifeq ($(BR2_NEEDS_GETTEXT),y)
-POWERTOP_GETTEXTIZE = YES
 POWERTOP_DEPENDENCIES += gettext
 POWERTOP_CONF_ENV += LIBS='-lintl'
 endif