hans: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 21 Feb 2015 12:45:12 +0000 (09:45 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Feb 2015 14:26:01 +0000 (15:26 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/hans/Config.in [new file with mode: 0644]
package/hans/hans.hash [new file with mode: 0644]
package/hans/hans.mk [new file with mode: 0644]

index a45b0f9873af5cec521c2556b6c49430ece6dad6..c169369a4970aa65d2b48bc9e75ebe466ab76d69 100644 (file)
@@ -1091,6 +1091,7 @@ endif
        source "package/fping/Config.in"
        source "package/gesftpserver/Config.in"
        source "package/gutenprint/Config.in"
+       source "package/hans/Config.in"
        source "package/hiawatha/Config.in"
        source "package/hostapd/Config.in"
        source "package/hplip/Config.in"
diff --git a/package/hans/Config.in b/package/hans/Config.in
new file mode 100644 (file)
index 0000000..7b60090
--- /dev/null
@@ -0,0 +1,13 @@
+comment "hans needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
+
+config BR2_PACKAGE_HANS
+       bool "hans"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         Hans makes it possible to tunnel IPv4 through ICMP echo packets,
+         so you could call it a ping tunnel.
+         This can be useful when you find yourself in the situation
+         that your Internet access is firewalled, but pings are allowed.
+
+         http://code.gerade.org/hans/
diff --git a/package/hans/hans.hash b/package/hans/hans.hash
new file mode 100644 (file)
index 0000000..c1a28df
--- /dev/null
@@ -0,0 +1,3 @@
+# From http://sourceforge.net/projects/hanstunnel/files/source/
+md5    97a93a886bc766212257198fd99d1061        hans-0.4.4.tar.gz
+sha1   8a21a9acc6d52cf7d2a5049523469e2609716ab3        hans-0.4.4.tar.gz
diff --git a/package/hans/hans.mk b/package/hans/hans.mk
new file mode 100644 (file)
index 0000000..bda091f
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# hans
+#
+################################################################################
+
+HANS_VERSION = 0.4.4
+HANS_SITE = http://downloads.sourceforge.net/project/hanstunnel/source
+HANS_LICENSE = GPLv3+
+HANS_LICENSE_FILES = LICENSE
+
+define HANS_BUILD_CMDS
+       $(MAKE) GCC="$(TARGET_CC)" GPP="$(TARGET_CXX)" -C $(@D)
+endef
+
+define HANS_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 755 -D $(@D)/hans $(TARGET_DIR)/usr/sbin/hans
+endef
+
+$(eval $(generic-package))