projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
cb54da1
)
xl2tp: fix static build
author
Baruch Siach
<baruch@tkos.co.il>
Sun, 23 Nov 2014 10:29:59 +0000
(12:29 +0200)
committer
Thomas Petazzoni
<thomas.petazzoni@free-electrons.com>
Mon, 24 Nov 2014 21:14:22 +0000
(22:14 +0100)
Use pcap-config to list dependencies of libpcap.
Fixes:
http://autobuild.buildroot.net/results/87f/
87ff92831d265d437aa0dfcfb99e954f76597761
/
http://autobuild.buildroot.net/results/cd5/
cd5487e76259752cbe58b171f9a58970916f7bb8
/
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xl2tp/xl2tp.mk
patch
|
blob
|
history
diff --git
a/package/xl2tp/xl2tp.mk
b/package/xl2tp/xl2tp.mk
index 0b2f7f1758f5f67a560975df76cbfa02f17482cd..abed7e851fa2c8f04f57f1a205b5dacf2c84defb 100644
(file)
--- a/
package/xl2tp/xl2tp.mk
+++ b/
package/xl2tp/xl2tp.mk
@@
-10,9
+10,13
@@
XL2TP_DEPENDENCIES = libpcap openssl
XL2TP_LICENSE = GPLv2
XL2TP_LICENSE_FILES = LICENSE
+ifeq ($(BR2_PREFER_STATIC_LIB),y)
+XL2TP_LDLIBS = LDLIBS="$(shell $(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs)"
+endif
+
define XL2TP_BUILD_CMDS
$(SED) 's/ -O2 //' $(@D)/Makefile
- $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+ $(TARGET_CONFIGURE_OPTS) $(MAKE)
$(XL2TP_LDLIBS)
-C $(@D)
endef
define XL2TP_INSTALL_TARGET_CMDS