gcc: disable libsanitizer for musl
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 5 May 2014 21:17:09 +0000 (23:17 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 5 May 2014 21:53:27 +0000 (23:53 +0200)
A build issue affects libsanitizer on musl toolchains, even with
previous versions of gcc such as 4.8.x, so we disable building
libsanitizer when working with musl.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gcc/gcc.mk

index 3274821d0c36c33c24d3c53cdeae726c9a748c81..741bb84ee25e63d71936eabc2b5a6cd25f1700b4 100644 (file)
@@ -122,8 +122,9 @@ ifneq ($(BR2_TOOLCHAIN_BUILDROOT_WCHAR),y)
 HOST_GCC_COMMON_CONF_OPT += --disable-libquadmath
 endif
 
-# libsanitizer requires wordexp, not in default uClibc config
-ifeq ($(BR2_TOOLCHAIN_BUILDROOT_UCLIBC),y)
+# libsanitizer requires wordexp, not in default uClibc config. Also
+# doesn't build properly with musl.
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT_UCLIBC)$(BR2_TOOLCHAIN_BUILDROOT_MUSL),y)
 HOST_GCC_COMMON_CONF_OPT += --disable-libsanitizer
 endif