linux: indicate proper CPE prefix
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 7 Jan 2021 21:13:34 +0000 (22:13 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 9 Jan 2021 16:06:01 +0000 (17:06 +0100)
The CPE type of the Linux kernel is special, it should be "o", unlike
all other packages that use "a". We therefore need to override
<pkg>_CPE_ID_PREFIX, so that the CPE ID of the linux package matches
with the CPE dictionary.

Reported-by: Matt Weber <matthew.weber@rockwellcollins.com>
Cc: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Tested-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
linux/linux.mk

index 648f6ea2a5f85c386eb62207ec2f2c9658cb8036..50d2ae3ff8d871d30a34bdbb72cd34a38efe848c 100644 (file)
@@ -14,6 +14,7 @@ LINUX_LICENSE_FILES = \
 endif
 LINUX_CPE_ID_VENDOR = $(LINUX_NAME)
 LINUX_CPE_ID_NAME = $(LINUX_NAME)_kernel
+LINUX_CPE_ID_PREFIX = cpe:2.3:o
 
 define LINUX_HELP_CMDS
        @echo '  linux-menuconfig       - Run Linux kernel menuconfig'