gstreamer{,1}: fix unaligned access detection for microblaze
authorPeter Korsgaard <peter@korsgaard.com>
Thu, 27 Feb 2014 08:19:18 +0000 (09:19 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 27 Feb 2014 08:19:18 +0000 (09:19 +0100)
Fixes http://autobuild.buildroot.net/results/f49/f4914bb3999c8a7a0c0a2afdac5de40fb9058372/

Similar to the existing handling for avr32 and xtensa. Also add it for
gstreamer1 for good measure as it was missing there as well.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer/gstreamer/gstreamer.mk
package/gstreamer1/gstreamer1/gstreamer1.mk

index 0667e38904ec1e312aa677612dd356494c3e90c3..4696876d396e7e116b00a55b8452f9afe7f763a3 100644 (file)
@@ -12,7 +12,7 @@ GSTREAMER_INSTALL_STAGING = YES
 # Checking if unaligned memory access works correctly cannot be done when cross
 # compiling. For the following architectures there is no information available
 # in the configure script.
-ifeq ($(BR2_avr32)$(BR2_xtensa),y)
+ifeq ($(BR2_avr32)$(BR2_xtensa)$(BR2_microblaze),y)
 GSTREAMER_CONF_ENV = as_cv_unaligned_access=no
 endif
 ifeq ($(BR2_aarch64),y)
index cf2a86d83ad9e6cd9e3c0695b27a1de72b3b3b4f..fe158cfe43d59bd6b1f74d34cf94c2554884fd2f 100644 (file)
@@ -14,7 +14,7 @@ GSTREAMER1_LICENSE = LGPLv2+ LGPLv2.1+
 # Checking if unaligned memory access works correctly cannot be done when cross
 # compiling. For the following architectures there is no information available
 # in the configure script.
-ifeq ($(BR2_avr32)$(BR2_xtensa),y)
+ifeq ($(BR2_avr32)$(BR2_xtensa)$(BR2_microblaze),y)
 GSTREAMER1_CONF_ENV = as_cv_unaligned_access=no
 endif
 ifeq ($(BR2_aarch64),y)