icu: speed up host build
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 9 Mar 2013 04:03:00 +0000 (04:03 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 10 Mar 2013 22:15:58 +0000 (23:15 +0100)
The host build of icu doesn't need to build everything, so we can add
a few more --disable-<foo> options to save a little bit of build time.

On a fast build server, this bring the host icu build from 2m28.517s
to 2m5.192s.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/icu/icu.mk

index 5a884968fdbd0e104de5503b112b5f2ccd1667b2..7658589e4ea86317f365e26b1de922289d62eb64 100644 (file)
@@ -15,7 +15,12 @@ ICU_INSTALL_STAGING = YES
 ICU_CONFIG_SCRIPTS = icu-config
 ICU_CONF_OPT = --with-cross-build=$(HOST_ICU_DIR)/source --disable-samples \
                --disable-tests
-HOST_ICU_CONF_OPT = --disable-samples --disable-tests
+HOST_ICU_CONF_OPT = \
+       --disable-samples \
+       --disable-tests \
+       --disable-extras \
+       --disable-icuio \
+       --disable-layout
 ICU_MAKE = $(MAKE1)
 ICU_SUBDIR = source
 HOST_ICU_SUBDIR = source