toolchain: add a hidden config option to enable the toolchain package
authorFabio Porcedda <fabio.porcedda@gmail.com>
Mon, 7 Apr 2014 09:56:48 +0000 (11:56 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 16 Apr 2014 17:37:08 +0000 (19:37 +0200)
The usual way to enable a package using the package infrastructure is to
use a config option so instead to add the toolchain package to the
TARGETS variable in the Makefile add a config option like all the other
toolchain packages.

[Thomas: remove comment that no longer made sense in the main
Makefile, and add a comment above the new hidden Config.in option to
explain what it is useful for.]

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile
toolchain/Config.in

index 137921ca257254bbc200ab3288d7ce1c6dfb9b74..0f8ca72b8802e8d2909efc0be7cd8c34a36bb431 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -294,14 +294,7 @@ unexport TERMINFO
 
 GNU_HOST_NAME:=$(shell support/gnuconfig/config.guess)
 
-################################################################################
-#
-# The list of stuff to build for the target toolchain
-# along with the packages to build for the target.
-#
-################################################################################
-
-TARGETS:= toolchain
+TARGETS :=
 
 # silent mode requested?
 QUIET:=$(if $(findstring s,$(MAKEFLAGS)),-q)
index 44f3ac66d81ee79cd3421111724b66e3843e32dd..a1065ac22889d7e0624fc213f67af3bc7c3f3dff 100644 (file)
@@ -1,5 +1,11 @@
 menu "Toolchain"
 
+# Invisible option that makes sure the toolchain package always gets
+# built
+config BR2_TOOLCHAIN
+       bool
+       default y
+
 # Should be selected for glibc or eglibc
 config BR2_TOOLCHAIN_USES_GLIBC
        bool