Remove support for shared configuration cache
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 4 Nov 2010 19:31:25 +0000 (20:31 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 5 Nov 2010 09:21:17 +0000 (10:21 +0100)
The configuration cache shared between packages, while being in
principle a nice idea to speed-up the configuration of packages by
avoiding repetitive identical checks, turned out to be unreliable due
to the subtle differences between similar but not identical checks in
different packages. After spending some time trying to fix those, we
concluded that supporting the shared configuration cache is definitely
too hard and too unreliable, and that we'd better get rid of it
altogether.

This patch therefore removes the shared configuration cache
infrastructure and usage.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
39 files changed:
CHANGES
Config.in
Makefile
configs/arm_nptl_toolchain_defconfig
configs/arm_toolchain_defconfig
configs/at91rm9200df_defconfig
configs/at91rm9200df_ext_bare_defconfig
configs/at91rm9200df_ext_defconfig
configs/at91sam9260dfc_defconfig
configs/at91sam9260dfc_ext_bare_defconfig
configs/at91sam9260dfc_ext_defconfig
configs/at91sam9261ek_defconfig
configs/at91sam9261ek_ext_bare_defconfig
configs/at91sam9261ek_ext_defconfig
configs/at91sam9263ek_defconfig
configs/at91sam9263ek_ext_bare_defconfig
configs/at91sam9263ek_ext_defconfig
configs/at91sam9g20dfc_defconfig
configs/at91sam9g20dfc_ext_bare_defconfig
configs/at91sam9g20dfc_ext_defconfig
configs/atngw100-base_defconfig
configs/atngw100_defconfig
configs/atstk1005_defconfig
configs/atstk100x_defconfig
configs/i386_defconfig
configs/i686_defconfig
configs/integrator926_defconfig
configs/integrator926_huge_defconfig
docs/buildroot.html
package/Makefile.autotools.in
package/fontconfig/fontconfig.mk
package/gamin/gamin.mk
package/haserl/haserl.mk
package/libxml2/libxml2.mk
package/multimedia/alsa-lib/alsa-lib.mk
package/ng-spice-rework/ng-spice-rework.mk
package/rpm/rpm.mk
package/sqlite/sqlite.mk
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

diff --git a/CHANGES b/CHANGES
index ac4cf60aab34b088c336a7164db1ece27e849bde..32bc6a7185d590d0377b862732f30af932de530b 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -16,6 +16,9 @@
        Download handling reworked and support for git/svn downloads
        added.
 
+       Removed experimental shared config.cache support, as it is
+       too unreliable.
+
        A convenience Makefile wrapper is created when using
        out-of-tree building, similar to how it is done for the kernel.
 
index b5d4084525e0627222c40a8929bc9bf162678d4f..a41cd3ef50a44438e9b562cac6017ff631c62a51 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -256,20 +256,6 @@ config BR2_HAVE_DEVFILES
          Install headers and static libraries in the
          target filesystem
 
-menu "Advanced"
-
-config BR2_CONFIG_CACHE
-       bool "Use a central configure cache file (EXPERIMENTAL)"
-       help
-         Notice: This is experimental and known to break with certain
-         package combinations.
-
-         This determines if a central config cache is used by
-         packages, reducing the configure time for packages as each
-         one caches its findings.
-
-endmenu
-
 endmenu
 
 source "toolchain/Config.in"
index 3664c960302726176b84752842301976d934d01d..18ca8b33d404d84f6622956b75723249f83cdd8b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -447,15 +447,6 @@ external-deps:
 show-targets:
        @echo $(TARGETS)
 
-ifeq ($(BR2_CONFIG_CACHE),y)
-# drop configure caches if configuration is changed
-$(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache: $(CONFIG_DIR)/.config
-       rm -f $@
-       touch $@
-
-$(BASE_TARGETS): | $(BUILD_DIR)/tgt-config.cache $(BUILD_DIR)/host-config.cache
-endif
-
 else # ifeq ($(BR2_HAVE_DOT_CONFIG),y)
 
 all: menuconfig
index d7b26a5b08744b74a87ba11129335fb6112d9e91..e167bc34a029bafea7435ad899badb0aac1098df 100644 (file)
@@ -155,7 +155,6 @@ BR2_OPTIMIZE_2=y
 #
 # Advanced
 #
-# BR2_CONFIG_CACHE is not set
 
 #
 # Toolchain
index 37426ae634f9f4bb812dbea2695c1bb756463983..d4642d96b3f65580015a6fb68538b178e4a5cd69 100644 (file)
@@ -160,7 +160,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index ac5bfa3c3887ea56a46c186b7151ed5246d9ef95..de061ac6bd14b4dfcfd295b4c11be3454a99a751 100644 (file)
@@ -165,7 +165,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9260dfc"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index 608460da08aead85c6926617cbf83de70d2cf09d..522daffbcf6deac0d7d849f3054ee256c0d979f6 100644 (file)
@@ -160,7 +160,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91rm9200df-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index 26ec52785958b1aa5f31c7d3e34f0b79b3f4839a..d030b1ef7fc9ca1858a420a44acaaf0e5ee04766 100644 (file)
@@ -171,7 +171,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91rm9200df-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index 50fa8effe8cc8390cae9f2c274bfc7ec1c8e7bba..1740e13ea588b61e36e2a498c7c444d265124bb4 100644 (file)
@@ -178,7 +178,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9260dfc-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index 9977e42eb56252185e0aa4661f65fb930e31fab9..bbaadfbd87e508454e63fcdac8d8edf27abc7f6e 100644 (file)
@@ -160,7 +160,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9260dfc-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index b46b8b0f53414f639acd9a51eb5fdfb948a67c62..1df49261cc0a4c6a8e4811b63c2b14481da7ce2c 100644 (file)
@@ -179,7 +179,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9260dfc-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index 2ef17485220e33d75c579f547b2b2906834a950f..f4c075551f69d4a643bd5720aa4378d4c49958cc 100644 (file)
@@ -181,7 +181,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9261ek-NAND"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index 6837f41255f7f7853319562edf8858e28f180f0a..ec86baef30dd7ef7671944f889b3bb98b9606958 100644 (file)
@@ -163,7 +163,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9261ek-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index 1f64123358917a5eab40a8ab04362c6e1afc9be0..39b5019bc4ce2bb3c8f9a3901eab074893266c94 100644 (file)
@@ -182,7 +182,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9261ek-NAND"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index df559da2d07b930da0432230790e88cb799d8d6f..cfa8742e083828d49aa5cacd7fca2bc472c96591 100644 (file)
@@ -179,7 +179,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9263ek-NAND"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index 81433185079d2dbd0ea60f868e5d4cf3c85bfbe3..54755ce35e0830bab7b376a5fd02ed646ba3f712 100644 (file)
@@ -162,7 +162,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9263ek-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index d044d05669f7a2839bb453fd893155def5d0e5a6..56605d9610ece7856915b9ac4b1017091f856653 100644 (file)
@@ -181,7 +181,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9263ek-NAND"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index 723932780adf888b03dcb94e5bcbd1978e15eb9d..dc9b600ff27f683d52c2f31aad1cb9318f25212b 100644 (file)
@@ -179,7 +179,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam92g20ek-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index a63706e890c9aef798efa94116853591550edc1f..c43c6f9be21003c74e95e4342361b66851652780 100644 (file)
@@ -160,7 +160,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9g20dfc-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index 02dd6b4ecb71208a4e179e5c883df7173d55bcd1..e61234b507da73daf61ac9de224934c97bb4109d 100644 (file)
@@ -179,7 +179,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="at91sam9g20dfc-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index ec3d4a0df617520344999abdc001b88d447e8f21..2b790153d59615bea7c7f8abeb19d66d9667b3f5 100644 (file)
@@ -112,7 +112,6 @@ BR2_TOPDIR_PREFIX=""
 BR2_TOPDIR_SUFFIX=""
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index 6d8293c557a897d9ffeeeab24653802f4d717219..ec87a09d2a4f6f1941817265ab38ba6f4aa53c87 100644 (file)
@@ -108,7 +108,6 @@ BR2_OPTIMIZE_S=y
 #
 # Advanced
 #
-# BR2_CONFIG_CACHE is not set
 
 #
 # Toolchain
index d0ec24d85c975b041627d495964578d38b26984e..6212e2bbdd2e82784e31c9ae49fdf32f0f7e3c6e 100644 (file)
@@ -111,7 +111,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index 6ee8f11dbaa827f828cd89b4fcd90740d948b312..ce509442b7a7103f9c388b88e0937362125873f8 100644 (file)
@@ -111,7 +111,6 @@ BR2_TOPDIR_PREFIX=""
 BR2_TOPDIR_SUFFIX=""
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index 672b694660154533d0a28df854d1cb352b26daf1..80100d604bca53928ffcc709909ae1529a3a4a0f 100644 (file)
@@ -113,7 +113,6 @@ BR2_TOPDIR_PREFIX=""
 BR2_TOPDIR_SUFFIX=""
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index 5b1b56fac3bb4e7067b94c33b2a23bfac6d29727..4a128e80244f3b49fd913e4ce444bc1c4ead36b1 100644 (file)
@@ -113,7 +113,6 @@ BR2_TOPDIR_PREFIX=""
 BR2_TOPDIR_SUFFIX=""
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index d7ccc653319e22707dc0eee01ac9a5ab73c5c8b2..fc2dccfd3b42e6873660fddc2ec0160ead4117c0 100644 (file)
@@ -110,7 +110,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index f88fcc7bd34712912a3d8f7e6c50c4186369cbb1..c56b6280099e5c06d3d9247dd7b5fc2dc1382caa 100644 (file)
@@ -110,7 +110,6 @@ BR2_TOPDIR_SUFFIX=""
 BR2_ROOTFS_PREFIX="$(BOARD_NAME)-rootfs"
 BR2_JLEVEL=2
 # BR2_DEPRECATED is not set
-# BR2_CONFIG_CACHE is not set
 # BR2_ENABLE_DEBUG is not set
 BR2_STRIP_strip=y
 # BR2_STRIP_sstrip is not set
index a94e7befa3488edb0d21e7b457204f77e2895346..0a0114a3b72b0b80c205ec57058a242edd0c4f29 100644 (file)
@@ -1269,13 +1269,6 @@ LIBFOO_POST_PATCH_HOOKS += LIBFOO_POST_PATCH_FIXUP
       not. Valid values are <code>YES</code> and <code>NO</code>. By
       default, the value is <code>YES</code></li>
 
-      <li><code>LIBFOO_USE_CONFIG_CACHE</code> tells whether the configure
-      script should use the central configure cache, which caches test
-      results from previous configure scripts. Usually, this variable should
-      be left to its default value. Only packages having issues with the
-      configure cache, can set this variable to the <code>NO</code> value
-      (but this is more of a work-around than a fix)</li>
-
       <li><code>LIBFOO_INSTALL_STAGING_OPT</code> contains the make options
       used to install the package to the staging directory. By default, the
       value is <code>DESTDIR=$$(STAGING_DIR) install</code>, which is
index 3e213693793c80d5eee33dc17e606f65daeb11ba..7d04e44012b987025da2a02a6ffe0a97b9605776 100644 (file)
@@ -64,7 +64,6 @@ $(2)_MAKE_ENV                 ?=
 $(2)_MAKE_OPT                  ?=
 $(2)_AUTORECONF                        ?= NO
 $(2)_AUTORECONF_OPT            ?=
-$(2)_USE_CONFIG_CACHE           ?= $(if $(BR2_CONFIG_CACHE),YES,NO)
 $(2)_INSTALL_STAGING_OPT       ?= DESTDIR=$$(STAGING_DIR) install
 $(2)_INSTALL_TARGET_OPT                ?= DESTDIR=$$(TARGET_DIR)  install
 $(2)_CLEAN_OPT                 ?= clean
@@ -88,7 +87,6 @@ define $(2)_CONFIGURE_CMDS
        $$(TARGET_CONFIGURE_ARGS) \
        $$($$(PKG)_CONF_ENV) \
        ./configure \
-               $$(if $$(filter YES,$$($$(PKG)_USE_CONFIG_CACHE)),--cache-file="$(BUILD_DIR)/tgt-config.cache",) \
                --target=$$(GNU_TARGET_NAME) \
                --host=$$(GNU_TARGET_NAME) \
                --build=$$(GNU_HOST_NAME) \
@@ -112,7 +110,6 @@ define $(2)_CONFIGURE_CMDS
                LDFLAGS="$$(HOST_LDFLAGS)" \
                 $$($$(PKG)_CONF_ENV) \
                ./configure \
-               $$(if $$(filter YES,$$($$(PKG)_USE_CONFIG_CACHE)),--cache-file="$(BUILD_DIR)/host-config.cache",) \
                --prefix="$$(HOST_DIR)/usr" \
                --sysconfdir="$$(HOST_DIR)/etc" \
                $$($$(PKG)_CONF_OPT) \
index 6cbe2eafe7228e48f54499dabcac38de68b358b9..a875e7490af69e63b0b3060bb10245fd8de60e78 100644 (file)
@@ -7,7 +7,6 @@ FONTCONFIG_VERSION = 2.6.0
 FONTCONFIG_SOURCE = fontconfig-$(FONTCONFIG_VERSION).tar.gz
 FONTCONFIG_SITE = http://fontconfig.org/release
 FONTCONFIG_AUTORECONF = YES
-FONTCONFIG_USE_CONFIG_CACHE = NO
 FONTCONFIG_INSTALL_STAGING = YES
 FONTCONFIG_INSTALL_TARGET = YES
 # This package does not like using the target cflags for some reason.
index db2769213c9136484d78795be38739dc4012a9d4..f0600b27c4ba258c443aaba0a0a75564a70dfc2a 100644 (file)
@@ -19,8 +19,6 @@ GAMIN_CONF_ENV = have_abstract_sockets=no
 
 ifneq ($(BR2_LARGEFILE),y)
 GAMIN_CONF_ENV += CC="$(TARGET_CC) $(TARGET_CFLAGS) -DNO_LARGEFILE_SOURCE"
-# the above doesn't work with shared config.cache
-GAMIN_USE_CONFIG_CACHE = NO
 endif
 
 GAMIN_DEPENDENCIES = libglib2
index 79f02410f149fc8cbecbeddec219c8fa53e6295d..a8585e827b783f3ff982164489d661bb067525f4 100644 (file)
@@ -11,8 +11,6 @@ HASERL_INSTALL_TARGET:=YES
 
 # force haserl 0.8.0 to use install-sh so stripping works
 HASERL_CONF_ENV = ac_cv_path_install=./install-sh
-# the above doesn't interact nicely with a shared cache, so disable for now
-HASERL_USE_CONFIG_CACHE = NO
 ifeq ($(BR2_PACKAGE_HASERL_WITH_LUA),y)
        HASERL_CONF_OPT += --with-lua=$(STAGING_DIR) \
                --with-lua-headers=$(STAGING_DIR)
index 820f4656dc9c9bc44c6a58f33929bd93962c69ea..387dce3c50d39c1d94fe44169e22c845eaa7e919 100644 (file)
@@ -13,8 +13,6 @@ LIBXML2_LIBTOOL_PATCH = NO
 
 ifneq ($(BR2_LARGEFILE),y)
 LIBXML2_CONF_ENV = CC="$(TARGET_CC) $(TARGET_CFLAGS) -DNO_LARGEFILE_SOURCE"
-# the above doesn't work with shared config.cache
-LIBXML2_USE_CONFIG_CACHE = NO
 endif
 
 LIBXML2_CONF_OPT = --with-gnu-ld --enable-shared \
index ee9d9bc5d6016e819c592eb247b820cfc517941f..a3d5fe4a874a8f67f7a85d00d8eab6d83d32deaa 100644 (file)
@@ -67,8 +67,6 @@ endif
 
 ALSA_LIB_CONF_ENV = CFLAGS="$(ALSA_LIB_CFLAGS)" \
                    LDFLAGS="$(TARGET_LDFLAGS) -lm"
-# the above doesn't work with shared config.cache
-ALSA_LIB_USE_CONFIG_CACHE = NO
 
 define ALSA_LIB_UNINSTALL_TARGET_CMDS
        -rm -f $(TARGET_DIR)/usr/lib/libasound.so*
index 7515d255d243c242ff1ef2907d65ecb380108a52..113b59dee9c11d0dc250819d523a81cb4efc0a3b 100644 (file)
@@ -11,8 +11,6 @@ NG_SPICE_REWORK_INSTALL_STAGING = NO
 NG_SPICE_REWORK_INSTALL_TARGET = YES
 
 NG_SPICE_REWORK_CONF_OPT = CFLAGS="-I$(STAGING_DIR)/usr/include"
-# the above doesn't work with shared config.cache
-NG_SPICE_REWORK_USE_CONFIG_CACHE = NO
 
 NG_SPICE_REWORK_DEPENDENCIES = xserver_xorg-server xlib_libXaw
 
index 0104f1719a3b78b3d4766d1a6e33b87ef10e8218..778982a722953d95a64ac54b91d3bce9b8d1612f 100644 (file)
@@ -12,8 +12,6 @@ RPM_DEPENDENCIES = zlib beecrypt neon popt
 
 RPM_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/beecrypt -I$(STAGING_DIR)/usr/include/neon -DHAVE_MUTEX_THREAD_ONLY" \
                ac_cv_va_copy=yes 
-# the above doesn't work with shared config.cache
-RPM_USE_CONFIG_CACHE = NO
 
 RPM_CONF_OPT = --disable-build-versionscript --disable-rpath \
        --without-selinux \
index cc74fd74ed14b31cc6efd08e7e89c7fdf39b8d05..847e77c8ec678e08963f65a5c3970a39d7dd4468 100644 (file)
@@ -15,8 +15,6 @@ ifneq ($(BR2_LARGEFILE),y)
 # --disable-largefile is passed, breaking the build. Work around it by
 # simply adding it to CFLAGS for configure instead
 SQLITE_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -DSQLITE_DISABLE_LFS"
-# changing CFLAGS doesn't work with config.cache
-SQLITE_USE_CONFIG_CACHE = NO
 endif
 
 SQLITE_CONF_OPT =      --enable-shared \
index d9ea57083cda416c8b4d1a709724aa99cc37f580..fed8c10f81285f149c96a13d8ec533d046713890 100644 (file)
@@ -11,7 +11,6 @@ XSERVER_XORG_SERVER_MAKE = $(MAKE1) # make install fails with parallel make
 XSERVER_XORG_SERVER_AUTORECONF = NO
 XSERVER_XORG_SERVER_LIBTOOL_PATCH = NO
 XSERVER_XORG_SERVER_INSTALL_STAGING = YES
-XSERVER_XORG_SERVER_USE_CONFIG_CACHE = NO # overrides CFLAGS
 XSERVER_XORG_SERVER_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) install install-data
 
 XSERVER_XORG_SERVER_DEPENDENCIES =     \