igh-ethercat: use release tarball instead of mercurial branch
authorArnout Vandecappelle <arnout@mind.be>
Wed, 27 Jun 2012 02:46:31 +0000 (02:46 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 27 Jun 2012 20:13:59 +0000 (22:13 +0200)
The Mercurial branch may change, which leads to non-reproducible builds.
So download a released version instead.

Also add configure option for e1000e.

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/igh-ethercat/Config.in
package/igh-ethercat/igh-ethercat.mk

index 764a021c501a8ba46a61b1cc2bf29aa39d3bb551..890bb1242e0a64f691ea10be686ada5391b2aa0b 100644 (file)
@@ -17,6 +17,9 @@ config BR2_PACKAGE_IGH_ETHERCAT_E100
 config BR2_PACKAGE_IGH_ETHERCAT_E1000
        bool "e1000 driver"
 
+config BR2_PACKAGE_IGH_ETHERCAT_E1000E
+       bool "e1000e driver"
+
 config BR2_PACKAGE_IGH_ETHERCAT_R8169
        bool "r8169 driver"
 
index b6ac5b8241369147a8d05149dc7b0c9a9d3ce053..f04eb57f3b20abf58cac09bb22900e2954d210a1 100644 (file)
@@ -1,8 +1,7 @@
-IGH_ETHERCAT_VERSION = stable-1.5
-IGH_ETHERCAT_SITE    = http://etherlabmaster.hg.sourceforge.net/hgweb/etherlabmaster/etherlabmaster/archive/
-IGH_ETHERCAT_SOURCE  = $(IGH_ETHERCAT_VERSION).tar.bz2
+IGH_ETHERCAT_VERSION = 1.5.1
+IGH_ETHERCAT_SITE    = http://etherlab.org/download/ethercat/
+IGH_ETHERCAT_SOURCE  = ethercat-$(IGH_ETHERCAT_VERSION).tar.bz2
 
-IGH_ETHERCAT_AUTORECONF      = YES
 IGH_ETHERCAT_DEPENDENCIES    = linux
 IGH_ETHERCAT_INSTALL_STAGING = YES
 
@@ -12,20 +11,9 @@ IGH_ETHERCAT_CONF_OPT = \
 IGH_ETHERCAT_CONF_OPT += $(if $(BR2_PACKAGE_IGH_ETHERCAT_8139TOO),--enable-8139too,--disable-8139too)
 IGH_ETHERCAT_CONF_OPT += $(if $(BR2_PACKAGE_IGH_ETHERCAT_E100),--enable-e100,--disable-e100)
 IGH_ETHERCAT_CONF_OPT += $(if $(BR2_PACKAGE_IGH_ETHERCAT_E1000),--enable-e1000,--disable-e1000)
+IGH_ETHERCAT_CONF_OPT += $(if $(BR2_PACKAGE_IGH_ETHERCAT_E1000E),--enable-e1000e,--disable-e1000e)
 IGH_ETHERCAT_CONF_OPT += $(if $(BR2_PACKAGE_IGH_ETHERCAT_R8169),--enable-r8169,--disable-r8169)
 
-# Since we download ethercat from source control, we have to emulate
-# the bootstrap script that creates the ChangeLog file before running
-# autoreconf.  We don't want to run that script directly, since we
-# leave to the autotargets infrastructure the responsability of
-# running 'autoreconf' so that the dependencies on host-automake,
-# host-autoconf and al. are correct.
-define IGH_ETHERCAT_CREATE_CHANGELOG
-       touch $(@D)/ChangeLog
-endef
-
-IGH_ETHERCAT_POST_PATCH_HOOKS += IGH_ETHERCAT_CREATE_CHANGELOG
-
 define IGH_ETHERCAT_BUILD_MODULES
        $(MAKE) -C $(@D) $(LINUX_MAKE_FLAGS) modules
 endef