gtest: install libgtest_main to staging
authorErico Nunes <erico.nunes@datacom.ind.br>
Tue, 20 Jan 2015 18:54:33 +0000 (16:54 -0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 25 Jan 2015 17:45:20 +0000 (18:45 +0100)
gtest provides a separate libgtest_main library with a default main()
implementation for tests with basic needs.
This separate library isn't being installed by buildroot. This patch
adds the installation of this library to staging during the install of
gtest.

Signed-off-by: Erico Nunes <erico.nunes@datacom.ind.br>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gtest/gtest.mk

index 3f3e8896d36029a6fd5462aa70480ea4c3e2cf15..7129c939d35753743e8c8407a777a17720564cf1 100644 (file)
@@ -27,6 +27,7 @@ endef
 
 define GTEST_INSTALL_STAGING_CMDS
        $(INSTALL) -D -m 0755 $(@D)/libgtest.a $(STAGING_DIR)/usr/lib/libgtest.a
+       $(INSTALL) -D -m 0755 $(@D)/libgtest_main.a $(STAGING_DIR)/usr/lib/libgtest_main.a
        $(INSTALL) -d -m 0755 $(STAGING_DIR)/usr/include/gtest/
        cp -rp $(@D)/include/gtest/* $(STAGING_DIR)/usr/include/gtest/
 endef