vim: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 21:23:10 +0000 (23:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:36:01 +0000 (01:36 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/vim/Config.in
package/vim/vim.mk

index b851627ca07d30f7fc324836ace895eee6c0a7e5..1469be8dbed31fab3b2c7057a3bd0bf60a4d8527 100644 (file)
@@ -4,7 +4,6 @@ config BR2_PACKAGE_VIM
        depends on BR2_USE_WCHAR
        depends on BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
        select BR2_PACKAGE_NCURSES
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          VIM Text editor
 
index ec494608e756ae6767823bd95861408efe1e4924..c235a08cd34e220f83bdd173678eece6049c8abd 100644 (file)
@@ -8,7 +8,7 @@ VIM_VERSION = v8.0.0329
 VIM_SITE = $(call github,vim,vim,$(VIM_VERSION))
 # Win over busybox vi since vim is more feature-rich
 VIM_DEPENDENCIES = \
-       ncurses $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) \
+       ncurses $(TARGET_NLS_DEPENDENCIES) \
        $(if $(BR2_PACKAGE_BUSYBOX),busybox)
 VIM_SUBDIR = src
 VIM_CONF_ENV = \