package/gnupg2: add readline optional dependency
authorRomain Naour <romain.naour@openwide.fr>
Tue, 23 Sep 2014 21:57:37 +0000 (23:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Oct 2014 20:45:24 +0000 (22:45 +0200)
This is to improve build reproducibility.

[Thomas: add --with-readline and --without-readline options to
explicitly enable/disable readline usage.]

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gnupg2/gnupg2.mk

index b0e72976bb9bbd2e5fa14553afc6af005942ee61..4b0a26e2541966b62377f60b51073d3d787660e0 100644 (file)
@@ -33,4 +33,11 @@ else
 GNUPG2_CONF_OPT += --disable-bzip2
 endif
 
+ifeq ($(BR2_PACKAGE_READLINE),y)
+GNUPG2_CONF_OPT += --with-readline=$(STAGING_DIR)
+GNUPG2_DEPENDENCIES += readline
+else
+GNUPG2_CONF_OPT += --without-readline
+endif
+
 $(eval $(autotools-package))