package/spice: enable slirp support
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 16 Dec 2012 06:56:18 +0000 (06:56 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 16 Dec 2012 20:35:27 +0000 (21:35 +0100)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/spice/Config.in
package/spice/spice.mk

index 08c3893f6741fd0f43c2c30824eb6bb4fcdf9a12..b1e187a634f1fee1b2dd07a3e3c7bb1accff58eb 100644 (file)
@@ -41,4 +41,11 @@ config BR2_PACKAGE_SPICE_GUI
          Say 'y' here to enable the Graphical User Interface (GUI)
          start dialog.
 
+config BR2_PACKAGE_SPICE_TUNNEL
+       bool "Enable network redirection"
+       select BR2_PACKAGE_SLIRP
+       help
+         Say 'y' here to enable network redirection, aka tunnelling
+         through a SLIP/SLIRP session.
+
 endif # BR2_PACKAGE_SPICE
index 0a5c58e17f634bf76dde60c9f95ac8ed3020dc6d..78ca202b1eb41d0ec5918923ea74d882385266e3 100644 (file)
@@ -22,7 +22,6 @@ SPICE_DEPENDENCIES    = \
 # We disable everything for now, because the dependency tree can become
 # quite deep if we try to enable some features, and I have not tested that.
 SPICE_CONF_OPT =            \
-  --disable-tunnel          \
   --disable-opengl          \
   --disable-smartcard       \
   --disable-automated-tests \
@@ -44,6 +43,13 @@ else
 SPICE_CONF_OPT += --disable-gui
 endif
 
+ifeq ($(BR2_PACKAGE_SPICE_TUNNEL),y)
+SPICE_CONF_OPT += --enable-tunnel
+SPICE_DEPENDENCIES += slirp
+else
+SPICE_CONF_OPT += --disable-tunnel
+endif
+
 SPICE_CONF_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages
 SPICE_MAKE_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages